Arctic Chat : Arctic Cat Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I have a 2004 dvx90 that has ran great up until now. It was fine when we last parked it. The next time we went to ride all was great till the CDI popped.... Litterally, it sounded like a black cat going off. I thought "no biggie" I bought a new one off eBay and put it on, the thing ran fine while it was idleing on the jack stand for a couple of minutes. I took off on it for a little test drive and I made it about 60 feet and it popped the CDI again, the last time it had a small dent from the inside out, this time it had split open half way around! Any help or insight would be greatly appreciated. here's the set up, the battery has been dead in it for some time, we usually don't worry about it because it is usually easy to kick start. My son does take it into deep water from time to time. The first time the CDI box popped I was jumping it off with my truck. The cables were still on it. It started and ran for a few, I revved on it some and POP!!! Funny thing is I never had any problems with it till I decided to run the valves. Ok what I have done. Pulled the wiring harness off the frame, layed it out on the table and separated each wire and checked for bare spots,nicks, cuts all that good stuff. I want to ohm the stator and reg/rec. but am unable to find any specs online. Any ideas??? And also, there are 2 wires yellow and white coming from the stator (and the blue/yellow pulse) Should there be continuity between the yellow and white wires?
 

·
Registered
Joined
·
2,627 Posts
Any bare wiring touching metal?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
No checked every inch of wire today. Took it off the frame, layed it on my work bench and opened up all the wrap and tape.... Traced out EVERY wire..... Nothing.....this is a nightmare. At 197.00 per CDI I gotta get this right. (That's from arctic cat by the way)
 

·
Registered
Joined
·
2,627 Posts
There's obviously something overloading the cdi box. Maybe the stator? Here's a link for free arctic cat factory service manuals. Just follow the testing procedures for the stator and what ever else runs through the cdi box. I've heard of them getting hot and not working but not exploding.

"K&T Parts House Lawn Mower Parts and Chain Saw & Trimmer Parts"
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
@spooln30 thanks, I'll definitely take a look at it, I called arctic cat today, they weren't much help, they told me " well it's either the reg/rec or stator. My CDI is already blown if I buy both stator and reg/rec I will have replaced the whole charging system. Which I may have to do. Hopefully the manual will tell what now to test what and I can get somewhere with this.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #8 ·
ok so I pulled the stator (cause I plan to replace it anyway) it tested ok, of course with the atv Not running i was not able to test the AC current from it. The coil tested within range,however the plug wire cap was WAY out... Surely that couldn't cause it.... Could it??? there was no test for the REG/REC. I assume they are either good or bad. The only test is output voltage with the atv running. So I will replace the stator and reg/rec buy a new CDI and cross my fingers.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #10 ·
@Krom, dude, seriously? After all this time??? lol I have the stator off plastics off,HAD the wiring harness off, you've seen it on the little 90's?? or do they all do it??? Man you just made me feel a WHOLE LOT better. That's only 40 bucks!
 

·
Administrator
Joined
·
2,605 Posts
@Krom, dude, seriously? After all this time??? lol I have the stator off plastics off,HAD the wiring harness off, you've seen it on the little 90's?? or do they all do it??? Man you just made me feel a WHOLE LOT better. That's only 40 bucks!

I've seen a couple of them do it. sometimes the cap pops and blows the epoxy clean out of the way, other times it just bulges.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top