Arctic Cat Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1 (Edited)
sled has no power. will run but when push throttle just bogs. stator ohm readings all good,tss unplugged, tps on throttle body ohm reading good,new fuel pump and pressure is 38psi idling and with acceleration. all ohms reading done by manual and all in specs. don't know where to go next. any help would be appreciated.
Thanks
walmartone.com
 

·
Registered
Joined
·
10,428 Posts
Sometimes a bog can be attributed to a worn clutch. Rollers get worn and weights get a bump in them. What are you working on and is it a 9 tower or 6 tower clutch?
Also make sure your carbs are spotless and all Jets and passages are clean.
 

·
Registered
Joined
·
302 Posts
sled has no power. will run but when push throttle just bogs. stator ohm readings all good,tss unplugged, tps on throttle body ohm reading good,new fuel pump and pressure is 38psi idling and with acceleration. all ohms reading done by manual and all in specs. don't know where to go next. any help would be appreciated
Make sure you can move the track by turning the secondary clutch. Remove muffler and run engine, may have a rodent nest in it. Inspect primary clutch for wear and tear.
 

·
Registered
Joined
·
10,428 Posts

·
Premium Member
Joined
·
3,108 Posts
actually 1991 was last year for ford
1994 isuzu pickup last carbed road legal from major manufacture
 

·
Premium Member
Joined
·
3,108 Posts
Sorry
Missed you were referring to the ford cars ran at indy.
1963 is the last year for ford carburetor .
 

·
Premium Member
Joined
·
3,108 Posts
we are wayy off subject.
i would have thought hooley carbs.
seems lotus built the ford engines for a while, on those weber carbs.
pretty sure buick used those webbers also
 
1 - 12 of 12 Posts
Top