Arctic Chat : Arctic Cat Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
320 Posts
Discussion Starter #1
OK guys, like the title says...yesterday i was breaking trail in over 2ft of snow and was climbing a fairly steep hill. When i would pin it, the RPM's would jump to 7k ish then slowly bogg down to 5k.. if i just held it there i would just burn the belt...i smelt it burn a couple times just trying to make it up this hill (about 200ft long)..IF i let off the throttle and came to a stop, it would accelerate normally then just fall on its face and start to burn the belt again...

This has been happening for a while now....i would notice a pretty big bogg in the midrange at crusing speeds before...but this is the first time where i actually made the sled work and it was burning my belt.

I pulled off my secondary and noticed that my sheeves are very hard to turn....i dont know if they're seized or what. When that plastic belt deflector bushing is all the way in without shims (sheeves open) i can pinch/squeeze both ends with my hands and there is alot of play side to side..a good 1/4 inch or so...

Is my secondary done? or primary? both? What do i do next?

Thanks
 

·
Registered
Joined
·
1,726 Posts
Have you had the secondary apart to check the sheave bushing? That sounds exactly how mine was when the secondary took a dump. Remove seconday and take the helix and spring tension off. Squeeze the sheaves and see if there is any play. Also look for flat spots on the rollers.
 

·
Registered
Joined
·
320 Posts
Discussion Starter #3
In an attempt to look for problems, i started taking apart the secondary. I used a peice of threaded rod to take it apart slowly...got as far as lossening all 9 torque screws at the back, then i was like; wait a minute, i dont know what the hell im doing!! lol so i tightened them back up and came on here to see how its done lol

I've taken apart skidoo clutches before, but these ones are new to me and didnt want to make things worse. There's no C-clip that holds it together?? so just back off those 9 screws behind the helix and it will come apart?

Also, after i opened up the secondary to remove my belt, i pulled the secondary off and i felt a lot of play between both sheeves when squeezing it side to side...is that because my clutch was open? or is my bushing yuckered?
 

·
Registered
Joined
·
1,726 Posts
If you can squeeze the sheaves and get play with the spring tension on it then my assumption is it is junk...wait till you get it apart and have no spring tension. You will really see how much play you have.

And yes...remove the 9 torx bolts to remove helix and spring. Did they loosen up ok for you? They typically need to be heated since they should have some loctite on the threads.
 

·
Registered
Joined
·
320 Posts
Discussion Starter #5
yeah it wasnt bad...they were snug but not too tight...i did it with a 1/4" rachet. They had blue locktite on them...i just put them back in tho; didnt have blue locktite to re-assemble.

yeah i could move the sheeves side to side when squeezing in my hands...AT LEAST a 1/4" of play...minimum. But this was with my shims removed (to remove belt) and sheeves were open...is this normal?

can i put new bushings in?
 

·
Registered
Joined
·
320 Posts
Discussion Starter #6
anybody know if the sheave bushings are replacable on 2006 f7 snopro DD secondary?
 
1 - 7 of 7 Posts
Top