Arctic Chat : Arctic Cat Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
275 Posts
Neither good nor bad.....its oil. Won't help you, but won't hurt you either.
 

·
Registered
Joined
·
120 Posts
I switched to the same oil. Some say its better for the power valves and some say it doesn't make a difference. I guess if you can get it cheaper than cat oil, go for it--I did. :beer_cheers:
 

·
Registered
Joined
·
114 Posts
I've been using it since about the 200 mile mark. I now amm close to 3000 miles, and the valves
are nice and clean. I'd say good! :thumbsup: :thumbsup:
 

·
Registered
Joined
·
49 Posts
Amsoil Intercepter seemed a little thinner oil than Klotz that I normally use. Yes its cheaper but my sled seemed to consume it alot faster.
 

·
Registered
Joined
·
367 Posts
When I bought my 2004 F-6 (used) from the original owner, he recommended using AMSOIL (that's what he used).....at any rate, his reasoning was that it was the cleanest oil (meaning less smoke). I don't know how true it is, but that's what I've been using, without incident.
 

·
Registered
Joined
·
78 Posts
I have a 2004 F6 and that is all i have used! I have around 3000 miles and still runs like the day i got it! Best bang for your buck if u ask me..
 

·
Registered
Joined
·
495 Posts
I'v been using amsoil on both our sleds, and they both have close to 3000 miles on them..nothing wrong so far. So i'd say its good.
 

·
Registered
Joined
·
169 Posts
i ran amsoil hp in my old sled and it ran great!! noticed the pistons were cleaner then when i bough tthe sled. i have now a 04 f6 and used interceptor the sled has 5400 miles on it and seems to be running ok will check after the season to see how the power valves look!! but i say amsoil is good by all means!
 

·
Registered
Joined
·
34 Posts
my 03 f5 blew up and i was running amsoil... the valves were clean. but pistion had signs of lack of oil. but since i bought it used with 700 miles on it (i think it was 2 long ago) anything could have happend before me.
 

·
Registered
Joined
·
275 Posts
<div class='quotetop'>QUOTE (wastedwagesracing @ Mar 7 2007, 09:41 PM) <{POST_SNAPBACK}></div>
my 03 f5 blew up and i was running amsoil... the valves were clean. but pistion had signs of lack of oil. but since i bought it used with 700 miles on it (i think it was 2 long ago) anything could have happend before me.[/b]

Explain further...how exactly did your pistons exhibit lack of oil?
 

·
Registered
Joined
·
6 Posts
I've ran Amsoil in almost all my 2 cycle engines...mainly boat motors for several years. Love the stuff!

Been using it in sleds for about 4 years, and run Interceptor in sleds with powervalves, like my F5's recently.

It is wonderful oil.

One thing I noticed with the F5 was the oil consumption, it drank oil and I needed to fill the oil tank after 125 miles. I tuned the oil pump down in each sled and it's much better...not running 30:1 anymore. I think I'm stretched out another 75-100 miles after the adjustments.
 
1 - 16 of 16 Posts
Top