Arctic Chat : Arctic Cat Forum banner
1 - 6 of 6 Posts

·
Premium Member
Joined
·
1,006 Posts
Discussion Starter · #1 ·
Well I should have known things were going too smooth, go to press thumbwarmer on back of throttle lever and snap. Guess I should not have offered to install father-in-laws hand and thumb warmers bang your head

Think some good adhesive and a little bit of solder would work??

Thanks for any comments.

[attachment=60812:100_4140.JPG]
 

Attachments

·
Registered
Joined
·
140 Posts
I'd say some solder and epoxy would be your best bet.

You may even consider epoxying the whole unit to another substrate to hold it all together. Maybe another circuit board or something.

Rick
 

·
Registered
Joined
·
83 Posts
Happened to me to , just soldered it back together and the rubber shrink tube holds it in place
have had no problems since.
 

·
Premium Member
Joined
·
1,006 Posts
Discussion Starter · #4 ·
Thanks for the replies guys, appreciate it! Used some heavy duty 3M adhesive last night, seems to be holding good now - going to put a dab of solder on it and back to the installation... :thumbsup:
 

·
Premium Member
Joined
·
19,631 Posts
I think that happened to Gabe when he installed it on my (his old) H1. I think he glued/epoxied it and it seems to work just fine).
 

·
Premium Member
Joined
·
1,006 Posts
Discussion Starter · #6 ·
Yeah although I'm sure they are all very similar (aftermarket and cat products), seems like a pretty flimsy setup. I really didn't push that hard and snap. Got'er all fixed up though - going to finish the install today.
 
1 - 6 of 6 Posts
Top