Arctic Cat Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
I'm having a problem with my headlights. The plastic holder and rounded ball stud just dont hold anymore. Is this a fluke thing or is it common? Thank for any input and/or fix ideas. (05 500LE)
 

·
Premium Member
Joined
·
1,427 Posts
Its pretty common on the 05's. The newer models have a slightly different set up that bolts right on where that ball stud is. Check for a different part no. on the 06's and for sure on the 07's. Your dealer probably already knows and it might be covered by warranty. Not sure about that I just put some steel tie wire around the plastic cage and twisted it to snug it around the ball stud. I'm pretty sure the parts are real cheap and you can fix it yourself. Someone who has already done it will chime in soon.

WC
 

·
Registered
Joined
·
83 Posts
I had to fix mine last june. I put new balls and plastic clips in. I think it was something like 8 - 12 dollars canadian. I can't really remember the price to be honest but it was cheap and easy to do. I was amazed at how the balls were worn out. It must be the dirt and bouncing around that they get. I did look into the new bolt on setup that the new bikes have but I couldn't wait for the parts as they would have had to be ordered as where the new balls and clips were picked up by a buddy right away.

Matt
 

·
Registered
Joined
·
279 Posts
i also had same prob ( 05 500), put SILICONE in cage and on ball,reinstalled allowed to cure.
lite is still adjustable,will take some impact before pop 'n off of mounts , sav"n the lite ass.
:thumbsup:
 

·
Registered
Joined
·
25 Posts
Discussion Starter #6
Thanks guys for the replys...looks like I have a few options..crap design still though. I love this site.... :thumbsup:
 
1 - 6 of 6 Posts
Top