Arctic Chat : Arctic Cat Forum banner
1 - 17 of 17 Posts

·
Registered
Joined
·
460 Posts
Discussion Starter · #1 ·
hi i just bought a set of twin pipes for my 98 ZR600efi with a clutch kit, efi chip, and a fuel pressure regulator. but the chip that i got is for a 99 ZR600efi. just curious to whats the dif and if there'd be any problems with me jamming it in my 98? and how does this stuff affect the reliablity of the sled compared to stock????

also what might i gain or loose with using the fuel pressure reg? and what do i do to adjust it? whats a good pressure to run?

any info will be appreciated. good or bad
 

Attachments

·
Registered
Joined
·
93 Posts
best bet is to call black magic, or just check part numbers to see if there the same on their website. There pretty friendly and helpfull there. Thats what i did when i had a question if the EFI pipes would fit on a carb( i changed from EFI to Carb) Did you get your pipes with the loud stingers? or the quiet ones? (Just wondering, because i have the brand new dual quiet silencer i havnt used yet, ended up making my own stingers)
 

·
Registered
Joined
·
209 Posts
i have the same sled as you but i have the single dd pipe and chip and regulator and it has over 5000 miles now wit no major issues. With my regulator it just has a screw and a gauge that will let me raise or lower the pressure. not sure what mine is set at but i just kept lowering it until i got the plugs to a nice tan color and left it there.
 

·
Registered
Joined
·
316 Posts
you bought those off jordan right. as for the chip, I know that with the d&d chip you cant run a 98 chip in a 99 but you can run a 99 chip in a 98. I dont think that helped you out at all but best be is to call black magic and see. I hot the BM head on mine from jordan and I deffinatly noticed a difference. did you get a chip puller
 

·
Registered
Joined
·
460 Posts
Discussion Starter · #5 ·
thats great advice. so i am going to try the 99 chip in my 98 and see how things go. and ya putting in the pressure reg and turning it down till my plugs get to the nice brown will work out good too cuz now they are on the black side.

thats good to hear Matt. and ya got the stuff from Jordan.
 

·
Registered
Joined
·
420 Posts
I ran that setup for years on my ZR6 EFI without ever touching the fuel pressure. With that setup I would rather run it without the regulator then attempting to lean it out to much. On the low end it really helped to have the NGK Iridium plugs to clean out any richness at idle.

Suggestions:

-Add the Black Magic SSx notched weights for better hole shots and pull through mid-range
-Cermaic coat the pipes, as they love heat, and this will keep them nice and hot and require less RPM's for optimum performance (Also they look great)
-Definitly run premium fuels
-Use NGK Iridium Plugs
-Change your upper sprocket in the chaincase to a 19- I was running 19/41 gearing and it ripped from holeshot to top-end
-Run 1.25 or above track, unless you are studded, this sled will be making really good power
-use the fuel pressure regulator as a guage, I would not lean it out to much, but just ensure it is within spec of the manual.

Have Fun!

ZRjohn
 

·
Registered
Joined
·
460 Posts
Discussion Starter · #8 ·
so i put on the pipes and chip and clutch that all came together and as a matched set from black magic. havent drove it yet but thurs i will. not sure if i like it engaging at 5500 but will try it out and see what happens. i have other things to throw in to bring that down. but first want to try it andsee what i get out it. if i dont like it i'll just sell it and put my stock stuff back in lol.
 

·
Registered
Joined
·
93 Posts
<div class='quotetop'>QUOTE (mudslinger @ Feb 26 2007, 10:41 PM) <{POST_SNAPBACK}></div>
so i put on the pipes and chip and clutch that all came together and as a matched set from black magic. havent drove it yet but thurs i will. not sure if i like it engaging at 5500 but will try it out and see what happens. i have other things to throw in to bring that down. but first want to try it andsee what i get out it. if i dont like it i'll just sell it and put my stock stuff back in lol.[/b]

you will like it, dont worry. That kit does a nice number for our sleds.
 

·
Registered
Joined
·
15 Posts
I have a 99 PS with the BM twins w/chip on it. Really like the mid to top end performace, but the bottom end is really flat. My engagement is around 5200 but it feels like it needs about 5800 as that is when you really feel it start to pull good. Is this like what you guys are experiencing too?

I ride in colo. above 8000' so my clutching is quite a bit different. I am running 42g orange/white, 49deg helix with yellow in secondary. Runs up to 8800 and holds it good, just no bottom end...
 

·
Registered
Joined
·
460 Posts
Discussion Starter · #13 ·
so i havent driven the sled yet. got it all installed though. sounds great going to try it thurs hopefully.

i emailed blackmagic about the chip being different and they said that the 98 and 99 have different airboxs and cylinders. so my cylinders have been updated already so just the airbox is different. want to look in a 99 airbox to see whats up and go from there.

am still going to ride it this weeknd but dont want to hammer it till im sure its all ok. i think black magic just wants me to buy a 98 chip. whats your oppinion?
 

·
Registered
Joined
·
460 Posts
Discussion Starter · #14 ·
well took it for a tear tonight. what a different sled. awsome performance sounds fantastic wicked power, more then i expected. dont know about top end etc. as i just went out n played in the powder for a couple hours. but suredo notice a diference already. so so far very happy and no problems will keep things posted as i find stuff out.:)

maybe post a pic or two of them under the hood too. lol
 

·
Registered
Joined
·
460 Posts
Discussion Starter · #15 ·
so got a few miles on the setup now. only thing i didnt like was the notched weights making the engagement so hi so i put in non-notched ones. very happy with it all. pics to follow.
 

·
Banned
Joined
·
14 Posts
I think I might have a chip for a 98 zr 600 efi for b/m twins. Mine had twin b/m pipes and used a "square" chip,it got wrecked and when I turned it into the insurance I think I kept the b/m chip,pm me if you end up needing one, I could look around for it,Smitty
 

·
Registered
Joined
·
908 Posts
TRUST ME RORRY AT BM KNOWS WHAT HE IS TALKING ABOUT HE WILL TELL YA IF YOU RUN THE 99 CHIP IN A 98 YOU WILL GET A LEAN CONDITION AT CERTAIN RPMS BECAUSE OF THE DIFFERENT AIRBOX CONFIG. YOU MIGHT BE ABLE TO GET A 99 AIRBOX AND MAKE IT BREATH RIGHT. I JUST WOULD HATE FOR YOU TO HAVE A BURN DOWN. BUT ITS UP TO YOU I WOULD CALL BM AGAIN AND ASK FOR RORRY HES THE MAN. MY 2CENTS
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top