Arctic Cat Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
ZR 580 with the battery. Was running great and then just died when we stopped for a break. Checked the ECU for any flashing codes and saw there wasn't any light at all when it was pulled over, Checked the fuse box and saw that the 3 amp fuse for the efi/ecu power was blown. Replaced it with another 3 amp fuse and it blew as soon as the key was turned on. Tried it with a 10 amp and then a 15 amp fuse and they all blew as soon as the key is turned on. I'm trying to find the short but not exactly sure where to look. What has power as soon as the key is turned to the on position? I know the fuel pump does, but where else should I look? Thanks in advance for any tips.
 

·
Registered
Joined
·
22 Posts
wondering if you figured out your problem? i have a 95 ext efi that was blowing 3 amp fuses. found 3 bare wires laying on tunnel.have to take seat off. it's where the wires come together from the tail light, motor and from the efi box. been trouble free for 4 yrs. now. wires are all in a loom except where they all come together. hope this helps.
 

·
Registered
Joined
·
727 Posts
There is a wire harness under the coolant tubes under the oil tank. They contain 12 volt and AC lighting wires. They will be crushed together and melted from the coolant heat. Separate and insulate with heat shrink tubing. I moved the harness dfrom under then tubes to over and beside the oil tank. has been running great for 4 years now. Mine was a 95 Wildcat Touring EFI.

BP
 

·
Registered
Joined
·
17 Posts
found more wires shorting on steering stem. someone before me has zipp tied wires to the moving stem tight and wore through wire . i was in garage and seen it spark when i moved handle bar while running . so happy to actually see it spark cuz now it is fixed and running for hours . only 3k miles on it . happiness again lol thanks !
 
1 - 5 of 5 Posts
Top