Arctic Chat : Arctic Cat Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
I tried everything except a new clutch and have injectors cleaned, well almost. As far as the clutch I'm guessing it's not the 9 bolt cat style but how do I tell? and how much are the parts and a good clutch kit going to cost when upgrading to the 9 bolt. Thing runs great if you do not punch it it but seems to load up at idle. Is this just they way this year and motor run? Anyone have one with no bogging issues? Would like to fix this issue if possible. Any help appreciated. This is an EFI 580 motor.
 

·
Registered
Joined
·
4,097 Posts
<div class='quotetop'>QUOTE (AC-EXT @ Feb 18 2007, 08:42 PM) <{POST_SNAPBACK}></div>
I tried everything except a new clutch and have injectors cleaned, well almost. As far as the clutch I'm guessing it's not the 9 bolt cat style but how do I tell? and how much are the parts and a good clutch kit going to cost when upgrading to the 9 bolt. Thing runs great if you do not punch it it but seems to load up at idle. Is this just they way this year and motor run? Anyone have one with no bogging issues? Would like to fix this issue if possible. Any help appreciated. This is an EFI 580 motor.[/b]
The original clutch will have only 6 bolts and will say Comet-Arctico, or Arctico-Comet on the cover. You could probably transfer your weights and spring to the new clutch, but might as well get a new spring. You'll need new pins, bushings and washers for the weights. As you describe is not the way that sled should run.
 
1 - 2 of 2 Posts
Top