Arctic Chat : Arctic Cat Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
I am all new to this and i have a 94 zr 580. It has been running fine for the last week until last night. I was crusing down the trail and lost all power, it will not go anywhere. When i came to a stop the engine stopped and died. After a few min.s of pondering on what it could be i tried to start it back up and it did. Not very well though, it would not get ablove 1,800 RPMS and sounds funny, not normal and some backfires. It will not spin the track so I had to get towed out of the woods (let me tell ya, I am glad I have friends that are willing oto come find me at 9 pm). I am afraid to try and start it back up because maybe i will cause damage to it? ANyone know anyhting please let me know..
 

· Registered
Joined
·
18 Posts
Discussion Starter · #7 ·
<div class='quotetop'>QUOTE (gixxer @ Jan 20 2007, 11:04 AM) <{POST_SNAPBACK}></div>
Looks like its time to replace the piston/rings and probably the jug.

The piston looks like it either detonated or is running lean.

The broken part of the piston, is it on the exhaust side ?

The thumb mark in the middle of the piston makes it look like its running lean.

You either have a clogged jet or port in the carburator from sitting, there might have been bad gas in there , and from sitting it dried out clogging the ports.

Just don't replace the piston/rings with out finding out what caused this because it will happen again if the carb. is clogged.

Pull the the jug off, maybe the piston skirt cracked and broke off the side of the piston, that could cause a lean condition also.

The jug will probably be in bad shape also.[/b]
yeah, the broken side is on the exhust side.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top