Arctic Cat Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
94 ext wont restart after turning off.
Did fire back up after putting battery on charger,was reading 12.4 before charging.it wouldn’t fire up with starting fluid.
Could it be a stator problem Not charging battery Or bad battery or something else i need to check.
im fairly mechanical but not with electrical any help guys would be appreciated.
thanks midwestern ditchbanger
 

·
Registered
Joined
·
3,981 Posts
Those old EFI systems were very sensitive to battery condition. I`ve heard many stories of batteries that test fine, but the computer just didn`t like them and a new battery solved all the problems. Maybe the battery is too old to fully recover and will never make the ECU happy. Try new battery before tearing in and replacing other parts.
 

·
Registered
Joined
·
9,933 Posts
^^^ this and are you getting a single red flash on ECU when you turn key on?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
  1. Those old EFI systems were very sensitive to battery condition. I`ve heard many stories of batteries that test fine, but the computer just didn`t like them and a new battery solved all the problems. Maybe the battery is too old to fully recover and will never make the ECU happy. Try new battery before tearing in and replacing other parts.
  2. ^^^ this and are you getting a single red flash on ECU when you turn key on?
    Those old EFI systems were very sensitive to battery condition. I`ve heard many stories of batteries that test fine, but the computer just didn`t like them and a new battery solved all the problems. Maybe the battery is too old to fully recover and will never make the ECU happy. Try new battery before tearing in and replacing other parts.
    ^^^ this and are you getting a single red flash on ECU when you turn key on?
  3. ^^^ this and are you getting a single red flash on ECU when you turn key on?
    i dont get a flash on the ecu and dont hear the pump when the key is on but i do hear the pump on when im pulling it over and it will start after about three pulls and does idle smooth
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5




  1. i dont get a flash on the ecu and dont hear the pump when the key is on but i do hear the pump on when im pulling it over and it will start after about three pulls and does idle smooth
[/QUOTEi
Im also new to the forum and still trying to figure how the forum works
 

·
Registered
Joined
·
9,933 Posts
There should be a little round window on side of the ECU. When all is good, it will flash RED once when key is turned on. Also, the the 96 and older EFI's when you turn key on, you should hear pump for 2-3 seconds, unless system has been run just recently and is holding pressure but that's rare.
When you start it, put a multi meter on it to test voltage on battery. It should be around 14.2 volts. These battery powered EFI's need at least 9 volts on a battery where all the cells are good to run properly. Any dead cell affects it.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
There should be a little round window on side of the ECU. When all is good, it will flash RED once when key is turned on. Also, the the 96 and older EFI's when you turn key on, you should hear pump for 2-3 seconds, unless system has been run just recently and is holding pressure but that's rare.
When you start it, put a multi meter on it to test voltage on battery. It should be around 14.2 volts. These battery powered EFI's need at least 9 volts on a battery where all the cells are good to run properly. Any dead cell affects it.
I had this happen last year and i know where the glass eye is and dont see a light a light
I bought it used last year ran it a couple times when we have snow looks like somebody's been in there it looks like a birds nest by the battery it just seems to happen after its ben run for a bit had it out yesterday for about 45mins dont know if somethings getting hot or what ill try a battery next winter were losing what little snow we have here in illinois
Again guys thank you for the help its a fun fast little ditch banger!
 
1 - 7 of 7 Posts
Top