Arctic Cat Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
10,084 Posts
Get a hold of Blaine or Kev on here. They are the electrical guru gods!!
 

·
Registered
Joined
·
6,671 Posts
Let us know what symptom you have. Do you suspect a fuel or ignition issue? Does the fuel pump run when you turn the key? Is there good spark? Did you have the wiring apart and not sure what goes where?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
Kev, i suspect the issue is lack of fuel. i have not had a chance to try to troubleshoot it myself yet because of where the sled is and where i am currently. he tells me he used to hear the fuel pump run to pressurize the system when he first turned on the key(yes it is the battery efi version). he does not hear the pump now. i suspect the pump relay that they want $90.00 from the dealer. i want to try to substitute a standard bosch automotive relay to see if it will run but don't know if the oem relay has any other components inside it as in diodes, resistors, etc. i am a electrical engineer and can surely resolve his issue but need schematic to do it properly. have you ever cut open one of the oem relays? what is in there?
 

·
Registered
Joined
·
6,671 Posts
I picked up a relay for about $20 from an automotive supply place. They matched it up for me and worked fine. Also there's 2 relays, maybe try swapping them and see if the fuel pump runs.

This diagram is from the clymer manual. See if it helps.
 

Attachments

·
Registered
Joined
·
4 Posts
Let us know what symptom you have. Do you suspect a fuel or ignition issue? Does the fuel pump run when you turn the key? Is there good spark? Did you have the wiring apart and not sure what goes where?
I picked up a relay for about $20 from an automotive supply place. They matched it up for me and worked fine. Also there's 2 relays, maybe try swapping them and see if the fuel pump runs.

This diagram is from the clymer manual. See if it helps.
Not sure where what goes where
 

·
Registered
Joined
·
4 Posts
Let us know what symptom you have. Do you suspect a fuel or ignition issue? Does the fuel pump run when you turn the key? Is there good spark? Did you have the wiring apart and not sure what goes where?
Don't know where what goes
 

·
Registered
Joined
·
4 Posts
Let us know what symptom you have. Do you suspect a fuel or ignition issue? Does the fuel pump run when you turn the key? Is there good spark? Did you have the wiring apart and not sure what goes where?
I was wondering why I can't get any power pass the electric fuel injection box
 

·
Registered
Joined
·
10,823 Posts
Are you getting power at all on the sled? If you do, do you get a single flash on the side of the ECU?
 
1 - 11 of 11 Posts
Top