Arctic Chat : Arctic Cat Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
93 cougar 440 revs up on starting
Hey guys, looking for past experience/ cat wisdom. I have a 93 cougar 440 l/c. It was pulling air into the fuel lines. Here are the steps I took ( may shed light on the revving problem)
- Took carbs off, cleaned out with spray
- Took slides out of carbs as well as choke cables and cleaned
- Checked all fuel & vac lines
- Rebuilt fuel pump (square)
- Re assembled everything
- Throttle cable stuck then became free
- Lost spark at this point but had fuel pumping
- Put in bypass plug at handle bars and got spark
- Fired sled up and it revs up enough to turn track

I'm by no means a pro mechanic. This sled is my first and I've ridden it maybe 40 miles before these issues. It's real clean, 1300 miles. Any ideas would be greatly appreciated.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2
I replaced thr throttle (TSS) bushings today, that fixed the spark issue. The slide on the mag side hung up, causing the high rev but it idles really high now. I purchased a new throttle cable assembly today. Hopefully I will have time to put it in tomorrow. Bogs a bit when I hit the gas then comes back. I think I'm on my way to getting this thing running right. Here is a video of the high idle. If someone has any ideas I would appreciate the help

http://i1126.photobucket.com/albums...9-9928-D35E0D50B4AB-8111-00000C0479CD3FE2.mp4
 
1 - 2 of 2 Posts
Top