Arctic Chat : Arctic Cat Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
103 Posts
Discussion Starter · #1 ·
Hey all thanks for reading. my 79 tigre i run in drags handles 1000' just fine but when i regear for 600' the chain jumps i assume from the factory spring tensioner. I am all stock class and for $ reasons need to stay there . anyone know what kind of mod or kit i can put in to get me hooked up and stay stock. I would like a bolt type like the new ones but will different chaincase work or can a kit be put in and will it keep me in the stock class. any input will help shes geared right and hooks like up a mofo so all i need is chain not to jump so i can get this tigre to yank my neck. I'm new at this and this sled is my way into drag racing so if I can get this I might run with the big dogs at vintage level anyways. Thanks in advance
 

·
Registered
Joined
·
39 Posts
Boy I like the old El Tigre. Really takes me back to the good old days. Are you sure it is the chain that is slipping and not the drive lugs on the track? If if is the lugs you can put in the anti-ratchet sprockets on the drive axle. If it is the chain, you may be able to have a block of aluminum tig welded to the side of your chaincase so you can thread a bolt type tensioner with a roller on it like some of the bigger newer sleds have. I have two Kawasaki 550's that I still get out and drag race from time to time. It is a lot of fun. Seems like you hardly see any vintage stuff around here anymore. Good luck with it. Later.
 
1 - 3 of 3 Posts
Top