Arctic Cat Forum banner

1 - 20 of 22 Posts

·
Premium Member
Joined
·
792 Posts
Discussion Starter #1
i was out for a ride today and i was out about a hour and then it felt slugish and i was thinking something is not right :eek: so i turn around to get to my parents place ( because it was not far away ) and after i turn around it did not sound right and had no get up and go then i shut off :eek: :eek: it did start right away but that did not last long and there is a bad grinding sound or something like that so i called the wife and had her come and get me with the truck


so i think i need to call the dealer tomarow and hope catcare covers it
 

·
Registered
Joined
·
1,317 Posts
Kinda wierd it happened after you did your exhaust mod....did you check ur spark plug to see if you fouled it out? Like i said i havent had and issues with mine but i can help but notice the coincidence
 

·
Premium Member
Joined
·
792 Posts
Discussion Starter #3
the spark plug is the first thing i looked at i forget what color is god or bad but mine was tan color ( if i remeber right ) anyone know were i could find pics of plugs that show whats good and whats bad



i dont think its the muffler mod because it was running real great after it
 

·
Registered
Joined
·
1,317 Posts
tan i think is the correct color..white is lean and black is rich...if i remember right black is better than white
 

·
Premium Member
Joined
·
1,673 Posts
<div class='quotetop'>QUOTE (Crash06 @ Nov 11 2009, 10:17 PM) <{POST_SNAPBACK}></div>
tan i think is the correct color..white is lean and black is rich...if i remember right black is better than white[/b]
yep
 

·
Premium Member
Joined
·
792 Posts
Discussion Starter #6
ya first thing after i got it home i pulled the plug to see what it was like and when i was taking it out i was just praying there was a end still on the plug HAHA but when i got it out it looked real good now even if it will turn over it does not sound good right after it happend i was looking it over and i did see that the coolant was not very hot ( like right after it happend when it had been running for a half hour ) and that just did not look right like i could yake the cap off and put my finger right in the coolant i took the cap off to make shure i still had coolant and the motor did not feal to hot my temp light was never on

o well i will give the dealer a call tomarow and take it up there friday dealer is one hour + drive
 

·
Registered
Joined
·
1,317 Posts
did you check all your fuses sounds like something isnt working right there...maybe the pump fuse blew? Id check that if i were yo because if it isnt gettin any fluid to cool it and your running it around it will seem like a dog and eventually you'll ruin your head gasket and finally seize the engine...worth a look especially if it saves you a drive
 

·
Premium Member
Joined
·
2,546 Posts
What "pump fuse" are you talking about?
 

·
Registered
Joined
·
1,317 Posts
wasnt sure if there was one...basically it was just tellin him to check all the fuses..lol
 

·
Premium Member
Joined
·
2,546 Posts
<div class='quotetop'>QUOTE (Crash06 @ Nov 14 2009, 07:19 PM) <{POST_SNAPBACK}></div>
wasnt sure if there was one...basically it was just tellin him to check all the fuses..lol[/b]

When you said that the only thing I would think of is the fuse for the fuel pump. If that was bad it would not start and you would get EFI flashing on the pod.
 

·
Premium Member
Joined
·
792 Posts
Discussion Starter #11
<div class='quotetop'>QUOTE (Crash06 @ Nov 14 2009, 06:19 PM) <{POST_SNAPBACK}></div>
wasnt sure if there was one...basically it was just tellin him to check all the fuses..lol[/b]
that was the very first thing i did

its at the dealer i will see how it goes
 

·
Premium Member
Joined
·
792 Posts
Discussion Starter #14
no info yet they have not gave me a call and i have not had the time to call them

i really need my bike back :wacko: i just cant go back to riding the little honda :D :lol:
 

·
Premium Member
Joined
·
2,546 Posts
<div class='quotetop'>QUOTE (mudweiser2005 @ Nov 24 2009, 09:55 AM) <{POST_SNAPBACK}></div>
So whats the verdict?[/b]
This is what he posted in a different topic:

"a bearing let go and so it need a new crankshaft, cylinder, piston and all the gaskets and stuff to put it all back together"
 

·
Registered
Joined
·
1,317 Posts
Damn...hopefully it wont be too expensive since i dont think he has the extended warranty
 

·
Premium Member
Joined
·
792 Posts
Discussion Starter #18
yep i got 2 years warranty :)
 

·
Registered
Joined
·
1,317 Posts
lucky man
 

·
Premium Member
Joined
·
792 Posts
Discussion Starter #20
its done Clap Cat happy Cat happy
 
1 - 20 of 22 Posts
Top