Arctic Cat Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello Arctic Cat Community,

I have 2018 90cc Alterra and I am having issues with the lights. ATV runs and starts fine but the running lights (if that what you call them) don't turn on. The brake light works which is weird because it looks like the same bulb is used for the running lights. I checked the wiring and it looks all to be in order (no broken/cut wires). The main fuse id fine too hence why it starts and runs. First time ATV owner and YouTube didn't turn up anything. Any help would be much appreciated!

Thanks,
beewhyguy
 

·
Registered
Joined
·
10,155 Posts
Maybe something in service manual. No other fuses?

 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
660catman - I did take a look at it. It just mentions the main fuse which I checked. The manual does not mention any other fuses.
 

·
Registered
Joined
·
10,155 Posts
Just making sure you have the key all the way over. ATV's usually have a RUN and LIGHTS position on the key. Not quite sure on the youth models though. Brake light would work in either position.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
60catman - My 450cc has a light's position. The 90cc ones, for safety reasons, turn on when started and you can not shut them off. If you can think of anything else please let me know. Thanks for the responses.
 

·
Registered
Joined
·
10,155 Posts
Then I can only think that the bulbs are burnt out and a possible regulator/rectifier issue that caused it.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
660catman - I originally thought the bulbs just burnt out but the rear brake light still working is throwing me off. Is it possible that the rear bulb is "partially" burnt out (if thats even possible)?
 

·
Registered
Joined
·
10,155 Posts
The rear bulb is an 1157 dual filament bulb. Headlamps are a single filament bulb.
 
1 - 8 of 8 Posts
Top