Arctic Chat : Arctic Cat Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I manage to start engine by pull. Just no electric start. Battery new/fine. Jumped posts on solenoid and she fires. Replaced solenoid and key switch. Still nothing. Been checking plugs, harnesses, and wires with no luck. Sure be nice to have a wiring diagram. Anybody have insights beyond mine?
 

·
Registered
Joined
·
14,294 Posts
You will need to do some continuity tests. Check the pins at the console plug. Wiring diagrams and service manuals can be downloaded from country cat . com under technical information.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Thanks. I did find the diagrams at Country Cat. Another headache I've experienced from day 1 is the machine refuses to shut off. Seems to happen after a hot run. Kill switch and toggling the key won't stop the engine. Just about when I'm heading for the plug wires, she dies. Had 2 dealers look at it early on with no fix. Notified factory too. Dealt with it for 5 years now! I'm having trouble connecting the run- on problem with starter issue. But it does tell me I probably always had a compromised electrical system. Harness or wiring problem no doubt.
 

·
Registered
2004 Arctic Cat 400
Joined
·
1,439 Posts
You have a bad ground someplace. Arctic Cats with missing/bad grounds run constantly. when you are moving something to go for plugs you are probably causing the ground to close the circuit and shut off.

Start chasing your ground connections and chassis grounds etc. add an extra or 2 and see if they help.
 
  • Like
Reactions: Steve A.
1 - 5 of 5 Posts
Top