Arctic Cat Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Currently looking for a clutch kit. I Contacted epi and others but to no avail cannot find a company who makes springs and rollers for the unit. I bought the unit with 653 miles with 29.5 terminators. The unit was very slow sluggish and rpms where very high staying in the 4000-5800 getting up to speed and even holding steady between 20-30mph. Once it got going it was ok ride wise. The dealer put a new secondary and new belt on it before I purchased due too reverse not working per what they told me. So I bought a new set of 6ply 26in tires Thinking that whoever put the 29.5 on didn’t do a clutch kit. Unit now starts creeping forward with ease but doesn’t fully engage it feels until 3500 rpms you get that engagement feel even though it is easier. Once going 10-15 mph it feels like a flat tire. Tried going up my driveway and unit stopped like belt was slipping had to romp into gas to get it to climb. So I was weary and took the clutch Belt housing cover off to see if they installed a new clutch. No mistaking it secondary is brand new as well as a brand new belt. Is it possible the spring and rollers are different that when they installed the new secondary they didn’t take the time to put the other springs/rollers to stock? How can I tell when I dissemble the clutches what kind is installed? What kind of clutch kit is available for this unit for basic Florida trail riding, some sugar sand and little mud? More acceleration torque lower rpm engagement im ok with 35-40mph top speed.
 

Attachments

·
Administrator
Joined
·
36,552 Posts
Did you try speedwerx ? Try looking on the kymco forums as that is a kymco engine.
 
1 - 3 of 3 Posts
Top