Arctic Cat Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Alright so long story short. My buggy is having a little bit of issue. My battery when tested and machine is off is showing 12.6 volts. When I first turn on the utv it goes to 14.5. But after sitting there for a little bit it seems to jump up to 15.33 volts. Was curious to see you guys thoughts. Thanks for all the help.
 

·
Administrator
Joined
·
37,083 Posts
15.33 is pretty high. I would get your battery load tested to confirm it is good. Then you will need to look at the vr/rectifier
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
15.33 is pretty high. I would get your battery load tested to confirm it is good. Then you will need to look at the vr/rectifier
Battery was tested and everything checked out on it. Arctic cat dealer suggested it may be a regulator but this is all new to me.
 

·
Administrator
Joined
·
37,083 Posts
Vr/rectifier = voltage regulator rectifier
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Vr/rectifier = voltage regulator rectifier

Alright so I took it in to arctic cat dealer today and he also tested the battery and everything came back as passing. But he was seeing the voltage as too low(maybe my voltage gauge is messed up or I’m not using it correctly.) running it would stay around 13.3. So he believes it’s actually not getting enough voltage and he said he was 99.9% sure it have to be the voltage regulator. So I have ordered one and it will be in next week. Hopefully this is the issue. I appreciate all the help.
 

·
Administrator
Joined
·
37,083 Posts
Did you get it ?
 
1 - 7 of 7 Posts
Top