Arctic Chat : Arctic Cat Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I have a 2011 Arctic cat 425 4x4 that I recently bought brand new. I took it out and was playing in some mud holes and fell in a deep water hole. It came out on its own but now when its in "High" it acts like it is not shifting. The motor revs high and it will only run about 10 mph. Is this something simple or did I screw something up already. Any help would be greatly appreciated.
 

·
Registered
Joined
·
1,023 Posts
its full of water theres a plug in the bottom of belt cover, pull plug drain water and drive around being real light on the throttle until it dries out "acts normal" reinstall plug and go.
 

·
Administrator
Joined
·
40,631 Posts
Just rev it gently in neutral till it gets nice and warm and dry.
 

·
Administrator
Joined
·
40,631 Posts
That would be the best. That way you can check your sheaves for bad grooves from slipping when you were trying to ride it. It will also give you an idea how to plan your snorkels:)
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
Thanks for all the info. I pulled the cover off last night and cleaned the rest of the mud out. I checked the sheaves an they are completely smooth. Put it all back together and it's back to running like it should. Where can I get a snorkel kit for my 4 wheeler?
 

·
Administrator
Joined
·
40,631 Posts
Home Depot :)
 

·
Premium Member
Joined
·
8,170 Posts
Stay out of the DEEP for a while. Enjoy your new ride. Small water is OK. Don't go deep until you are ready for the consequences. It's a Cat but it can't swim.
i beg to differ.. water riding is 100% prep

 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top