Arctic Cat Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Sled runs great when horizontal or going down hill. When climbing after a short distance, 100 ft or so, sled will stall. Will fire right back up, if continuing to clmb will stall again. If turning around going downhill, runs fine. Anyone seen this or any ideas?
 

·
Registered
Joined
·
10,155 Posts
Sure sounds like an issue with one of the front fuel pickups. However, if it still does it with a full tank, I’m not sure what it would be.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thanks for the reply. Thought the same or even bad gas so top it off with fresh and still the same. Did put some injector cleaner in the gas so will see what happens.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
I know its been awhile and do appreciate all the feedback so will provide what I have at this time on this issue. It did still have the issue with a full take of gas. I tried the Injector cleaner and it did seem to be better but not 100%. Ended up bringing it in to a local shop, he said the Lower Clutch needed to be replaced, also said belly cover was compromised and therefore snow getting up inside. Neither make sense to me as I'm a novice but if the Clutch needed replacement I got that done. It did hesitate once on the throttle so maybe be that was the clutch. Long story short, I haven't been able to get back to camp to pick it up and rapidly running out of daylight this season. I will however pass along the outcome as soon as I get a chance to take it out.
 

·
Administrator
Joined
·
19,995 Posts
Clutch replacement sounds fishy. If anything, I’d suspect upper (secondary/driven) clutch instead.

And with as many sleds as I seen come into work with fuel pick-ups that failed this season (inside of fuel tanks on sleds of around that vintage), it very well could be an internal tank hose that has rotted and no longer is doing it’s job.
 

·
Premium Member
Joined
·
945 Posts
Heck I agree with the fuel pickup too. My 80 Blizzard fell off this season too as i was riding around the yard. Took it in the garage had it fished out with my handy dandy fishing hook coat hanger laying around just for this occasion even ! Fixed and ready to go in less than 30 minutes. Riding time 10mins - 30mins to fix. Gee that sounds familiar for 1980 riding!

Steve
 
1 - 8 of 8 Posts
Top