Arctic Cat Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
So my buddy has an arctic cat 550 efi h1 hes done a bunch of work to the atv and we were riding and the atv would not hold a charge while riding at night with the lights on so we brought it back and did a voltage test and we were getting 13.1v but it would back fire and turn off it hasnt started since so it sat for a year well he took it to somebody they told him the ecu was bad so he bought another one and the stator was bad so he got it, installed it and still no spark no start i told him let me check it out i checked the codes and there were 8 of them so i cleared them to see what would stay and iam getting sc12 crank position sensor after a new stator and pick up voltage regulator ecu and spark plug and coil battery where installed. While cranking efi flashes so i checked and sure enough sc12 check the battery connections and charge battery is at 12.7v im out of ideas
 

·
Administrator
Joined
·
38,411 Posts
Get the battery load tested. They are very voltage sensitive. You should be seeing high 13’s to low 14’s at the battery when running.
Start with the battery
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Get the battery load tested. They are very voltage sensitive. You should be seeing high 13’s to low 14’s at the battery when running.
Start with the battery
Cant get the bike to start but its a brand new battery
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Found the problem the pick up was installed wrong more facing the outter case and not able to read the fly wheel marks flipped the pick up and it fired right up my buddy was pissed he wasnt able to ride for a year and put so much money into it
 
1 - 5 of 5 Posts
Top