Arctic Cat Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
New guy here, I just got a 2010 700 trv with 1000 miles on it, I took it out this weekend and Saturday it ran good, Sunday we took it out and on the way back to camp, it started spitting and sputtering and no power, then it would get power and run fine but as soon as I let off the throttle, it went back to act like it was starving for gas and just spit sputter and backfire, plug is good and the plug wire is good, after I hooked it back up it started but sont stay idling, it just dies and no power with spitting and sputtering, I'm lost as what to check next
 

·
Registered
Joined
·
146 Posts
Lack of power like its starving for more fuel? Sounded like my 2011 550 TRV before I found its solution. Sometimes, it ran like it had to push a large gallstone out of its fuel system. re: Like it had bad junk in its fuel injector. Ouch!

As a suggestion, install 1/2 bottle of Lucus Tune-Up / Injection cleaner in its full tank. And, only use FRESH Premium 91 / non-ethanol fuel. This worked for my AC engine.

re: "Lucas 10020 Fuel treatment - 5.25 Ounces"

Note: Do shop around cause prices for same product does dramatically vary.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I got some and gonna try it, the day before it started running like crap, I ran premium and the next day I filled it with unleaded and then it started running like crap
 

·
Registered
Joined
·
146 Posts
If you do a historical search, you'll find a similar problem where the guy pulled (removed) its Injector from its Throttle Body and discovered its tip was 1/2 filled with sand. Try above mentioned Lucas Injector Cleaner first. If that doesn't work, physically remove its injector and clean it. If that doesn't work, check its entire fuel system system for air leaks and its fuel pump has consistent 42-45 PSI. And, its in-tank filter is clean. If you think its "starving for fuel", then focus on its different fuel delivery areas. Hope this helps....
 

·
Registered
Joined
·
146 Posts
GuideZilla

Since your original Opening post, have you resolved your ATV's engine problem? If yes, please share the resolution details. Hoping this will help others - who might have similar engine behavior.
 
1 - 5 of 5 Posts
Top