Arctic Cat Forum banner

1 - 5 of 5 Posts

·
Premium Member
Joined
·
191 Posts
Discussion Starter #1
Purchased this atv over the weekend and had 1564 miles on it. Took it for a ride a 3 miles later it died and wouldn’t start. Took off the clutch cover and couldn’t turn over the engine very easily. Drained the oil in a clean pan and see some metal flakes. Previous owner put 20 miles on this spring and said ran fine. Are there issues with this engine?
 

·
Registered
Joined
·
2,029 Posts
Purchased this atv over the weekend and had 1564 miles on it. Took it for a ride a 3 miles later it died and wouldn’t start. Took off the clutch cover and couldn’t turn over the engine very easily. Drained the oil in a clean pan and see some metal flakes. Previous owner put 20 miles on this spring and said ran fine. Are there issues with this engine?
Yup.. sounds like it

Sent from my SM-G970U using Tapatalk
 

·
Premium Member
Joined
·
191 Posts
Discussion Starter #3
I guess I was referring too if the 550 had known engine issues. After straining the oil looks like maybe a bad rod bearing.
 

·
Administrator
Joined
·
37,308 Posts
I would say the previous owner screwed you over. That is one of the most bullet proof engines in the cat line up. Very reliable and for the most art trouble free.
 

·
Registered
Joined
·
189 Posts
I saw a few 550s with bad rod bearings. They made quite a bit of racket before they went, though. I agree with doorfx, I think the last owner knew something was up and got rid of the machine. For the most part the 550 is a fantastic engine.
 
1 - 5 of 5 Posts
Top