Arctic Chat : Arctic Cat Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
it started slipping going up a steep hill in low gear so i installed new belt and it still slips and makes a noise from rear diff as it slips, is this the turf saver causing the problem? I dunno
 

·
Registered
Joined
·
2,627 Posts
I'm not sure what a turf saver is?
How many miles and mods does it have and what kind of oil are you running? It must be wet clutch safe oil and should say JASO-MA on the bottle. Also when you say slipping does the engine rev up and not go any faster?
 
  • Like
Reactions: matt1964

·
Administrator
Joined
·
40,727 Posts
You can get an aftermarket kit that will never dlip
 

·
Registered
Joined
·
2,627 Posts
If y'all don't mind what is the sld?
 

·
Administrator
Joined
·
40,727 Posts
I thought it was spike load dampener ?it is basically a clutch that sits in the nose cone of your rear diff. When too much torque is applied it slips to stop parts from breaking. Two problems are
In 4x4 when it slips all torque gets transferred to the front drive line which can break things

Once it slips it just keeps getting worse until you replace or weld it
 

·
Premium Member
Joined
·
4,547 Posts
it started slipping going up a steep hill in low gear so i installed new belt and it still slips and makes a noise from rear diff as it slips, is this the turf saver causing the problem? I dunno

No turf safer in the 1000. Sounds like the sld, put it in 4x4 and go up the hill. no noise it's the sld. weld or replace sld, problem solved.

If it makes noise in 4x4 too then it might be a clutch issue.
 

·
Registered
Joined
·
66 Posts
Anyone know how to install the spike load delete kit?

Sent from my SM-G920V using Tapatalk
 

·
Administrator
Joined
·
40,727 Posts
  • Like
Reactions: jwfordracing

·
Registered
Joined
·
66 Posts

·
Administrator
Joined
·
40,727 Posts
  • Like
Reactions: jwfordracing

·
Registered
Joined
·
66 Posts

·
Administrator
Joined
·
40,727 Posts
Did you get it fixed? Did you make a utube video? :)
 
  • Like
Reactions: jwfordracing

·
Registered
Joined
·
66 Posts
Did you get it fixed? Did you make a utube video? :)
Lol, nope. I haven't even bought the part yet. It sounds pretty easy after you take the bed off.

Sent from my SM-G920V using Tapatalk
 
1 - 16 of 16 Posts
Top