Arctic Chat : Arctic Cat Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hey!

Peter from Sweden here, I have an Artic cat Thundercat 1000 from 2008 which I use to pull a timber cart with, it gives me a little headache, EFI starts flashing after a few minutes of driving and then I get error code SC98, it goes as it should, no problems with power or so. Have searched and read all the threads I find about this and tried the following in my troubleshooting:

Checked volts while driving, it never goes over 15 volts (which I can think is a bit high but have read that it's ok)

Check all fuses and measure the diodes.

Checked the contacts behind the control box and instruments, everything looks ok. No pin has gone backwards or so. Have also tried pulling a cable tie around the contacts to ensure that they fit properly.

Checked the cables between control box and instrument, (33 and 34 on control box against 18 and 20 on the instrument) have OHM measured and find no interruptions or contact with earth or other cables. (Can of course not measure while driving)
Font Rectangle Urban design Art Parallel


Automotive fuel system Motor vehicle Automotive tire Green Automotive design


Automotive tire Grey Motor vehicle Vehicle Gas

Have ordered new spark plugs at home but doubt that it will be able to make any difference.

Motor vehicle Steering part Gauge Automotive lighting Automotive design


Does anyone have an idea on how to proceed? I'm going crazy soon ...
Tire Wheel Plant Sky Vehicle
 

Attachments

·
Administrator
Joined
·
42,238 Posts
Get your battery load tested.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Do you think it can be that simple? Hope so. I have ordered a new quality battery, the old one slows down a bit when I pull the starter motor but as I said, the voltage never dips (what I can see ...)
 

·
Administrator
Joined
·
42,238 Posts
Did your old battery test bad ? The sc98 is a stored code ( not active). Did you try to clear the codes?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
Did not test it, it was pretty slow whith the starter so i just bought a new.

I have cleared the codes hundred times by now... Yes stored codes but keeps coming directly after clearing 😢
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
Not that it should effect anything but I discovered an leaking water pump and have ordered new sealings for it, i takes up to a month to get the parts to Sweden before any serius further fault searching but I need more tips for what to do?


Motor vehicle Automotive tire Hood Gas Automotive exterior


/Peter
 
1 - 7 of 7 Posts
Top