Arctic Cat Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I Recently picked up a used 2008 Arctic Cat 366 4x4 and noticed that the buttons next to the speedometer do not work. However the speedometer works and so does the gear indicator and the high beam light. Has anyone else had these issues? If so how did you fix them. Also I looked online and couldn’t find a replacement gauge. I included a picture of it. Let me know if anyone knows where I could maybe get a replacement, or find info on it.
364684
 

·
Registered
Joined
·
194 Posts
My guess is that the gauge is bad, but you could try unplugging it and plugging it back in and see if the buttons come back to life. Did you try holding down one of the buttons for a little bit to see if it changes anything? The gauge part number is 3313-678 and is listed under the handlebar assembly.
 

·
Premium Member
Joined
·
1,517 Posts
I Recently picked up a used 2008 Arctic Cat 366 4x4 and noticed that the buttons next to the speedometer do not work. However the speedometer works and so does the gear indicator and the high beam light. Has anyone else had these issues? If so how did you fix them. Also I looked online and couldn’t find a replacement gauge. I included a picture of it. Let me know if anyone knows where I could maybe get a replacement, or find info on it. View attachment 364684
You have to hold the button in for a few seconds for anything to happen. Left button will cycle between displays, Pressing both will reset or set the current display, (set the time, or reset the trip odometer, etc..) pressing both also takes a second or two to react.

Mike
 
1 - 3 of 3 Posts
Top