Arctic Cat Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
My son just took our 07 H1 on it`s maiden trail ride after engine rebuild, we purchased this unit with a bad motor, had it rebuilt, we have only been plowing and light riding around neighborhood for the last 15 hours since rebuild. He took ATV on trail ride this past weekend and could only get to 40 mph max, engine seems to be running like a watch any ideas would be helpful

Jerry
 

·
Premium Member
Joined
·
1,585 Posts
Take it out of LOW range!! No seriously, did you have it in High range? You need to run High unless you absolutly need the low gears.
 

·
Registered
Joined
·
5,049 Posts
thats what i was gonna say, but my H1 didnt go 40 in low.
I wonder if the belt isnt riding up the sheaves all the way
 

·
Registered
Joined
·
330 Posts
Thats gotta be High. No way in hell are you gonna get an H1 up to 40 in low. Not unless you raise the rev limiter to 9500 rpm. I would say take the primary apart and check the rollers to make sure they are clean and not binding up.
 

·
Premium Member
Joined
·
1,585 Posts
Maybe it's in low, but the speedo is on Kilometers instead of Miles???? Just posting ideas.........IDK
 

·
Registered
Joined
·
25 Posts
Discussion Starter #7
Definitely not in low gear. could it carb problems? Shoild be covered under extended warranty correct?
 

·
Premium Member
Joined
·
1,585 Posts
Who did the rebuild? Dealer? Then YES. It should be running properly when they return it to you.

Just a thought, but they didn't turn in the throttle stop screw to keep it from being over revved while in the break in cycle did they?
 

·
Registered
Joined
·
74 Posts
The only problems I've had with my 650 H1 (TRV) was the belt getting wet and slipping (you would hear that) and the carb getting gummed up and not opening all the way. I couldn't hear anything different with the carb. I had the throttle pressed all the way but it would only get up to about 30mph.
 

·
Premium Member
Joined
·
1,553 Posts
If you got water & dirt in the belt housing my be the problem , I would say pull it off and clean it & rollers and check belt..
also
May have a clog jet, had a small piece of trash in my main jet and ran like crap, after that I installed a inline fuel filter
 

·
Premium Member
Joined
·
199 Posts
Is the valve timing correct? If you are off a couple teeth on the gear it could give you that problem.
----------------------
07 650 trv stock for now
 

·
Registered
Joined
·
10 Posts
My buddy's quad did the same thing. I took the clutches apart, washed the belt with soapy water (and green scrubby), washed both clutch faces with soapy water (again green scrubby on clutch faces to clean off glaze). Now it's completely fine.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #13
I called dealer who did rebuild he thought maybe diaphram in carb, or dirty carb, he said if was carb would be warranty, I guess I`ll take it in.

Jerry
 

·
Premium Member
Joined
·
1,585 Posts
Keep us updated Jerry. Let us know what they find.
 

·
Premium Member
Joined
·
19,631 Posts
What was the reason for the rebuild? If it was swamped, then I would make sure that the dealer took the extra 5 minutes to check the clutches to ensure they were 100% cleaned. Secondly, I would make sure the carb was cleaned inside and out. Lastly, I would check the air filter to ensure it's clean. My money is on one of those three things.
 
L

·
Guest
Joined
·
0 Posts
may be something as simple as a severly dirty air filter. also on the H1 there is water trap under the front fender that the air induction hose going to the air box is connected to. it could be full of mud,dirt.trash etc. just a thought.
 

·
Registered
Joined
·
183 Posts
well remember this and it goes with all brands you can have the best atv in the world but if you have an idiot turning the wrenches on it then there is no telling what you will get. So many people give the company a bad rap when some one just didn't do quality service on the machine itself.
 

·
Premium Member
Joined
·
19,631 Posts
<div class='quotetop'>QUOTE </div>
well remember this and it goes with all brands you can have the best atv in the world but if you have an idiot turning the wrenches on it then there is no telling what you will get. So many people give the company a bad rap when some one just didn't do quality service on the machine itself.[/b]
Amen brother!
 

·
Registered
Joined
·
9 Posts
i have a 650 h1 trv that i can not get over 40 mph to i just had the oil pump gear replaced oil pump had the carb gone threw it still seems noisey like the valving is sloppy but i have adjusted it to .004 and .006 i replaced the 2ndary clutch and i looked at all the rollers on the primary i also replaced the centrifugal clutch and still only get 40 it does have oversided tires on it by one size that will only change the speed by 2.5 mph i am at a loss one dealler tells me top speed is 40 and another dealer says 55
 
1 - 20 of 22 Posts
Top