Arctic Chat : Arctic Cat Forum banner
21 - 37 of 37 Posts

·
Administrator
Joined
·
40,392 Posts
 

·
Registered
Joined
·
11 Posts
Are you sure your bike is changing into high gear and not low gear? Sounds like the bike is rev limiting itself in low gear.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #24 ·
Latest update, to confirm Doorfx's question, pulled carb again, float is confirmed to be 17 mm. Pulled clutch cover, belt was at 35 mm, replaced as manual says at minimum (newly installed belt is 37 mm). Found good deal on Dynojet kit, so installed that while carb was off. Replaced air filter after tearing the one that was on there. All back together, took for a ride...no change....aaaargh!!!!!! What next????
 

·
Administrator
Joined
·
40,392 Posts
Did you put the PMS assembly back in the correct order ? There is an o-ring, spring and washer.

Is this correct ?


No holes , rips or tears in the diaphragm? It is seated correctly in the groove?

 

·
Registered
Joined
·
25 Posts
Discussion Starter · #26 ·
Put spring, then washer, then o ring onto the screw then installed. I held diaphragm up to bright light and pulled and stretched lightly looking for any light to come through, which i saw none. Installed diaphragm three seperate times, and seemed to fit easily and properly each time. Makes a nice whoosh sound with some resistance when the slide is moved and tested by blowing some low pressure air into upper cavity which raised the slide. Is there any other way to test the diaphragm and installation to ensure it is good & installed properly?
 

·
Administrator
Joined
·
40,392 Posts
 

·
Administrator
Joined
·
40,392 Posts
When you set the valves are you sure you were on TDC compression and not TDC exhaust ? The timing marks will line up on both.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #29 ·
Alright here is the latest, still doing as originally described. Once i go to wide open throttle, it seems to back fire/misfire, what seems to be through the carb. Top speed of 50km/hr, confirmed with a GPS.

Recap of what has been checked and or done:
  • Valves have been set to .003 in and .005 ex, and reset again to confirm it wad at compression TDC
  • spark arrestor checked, completely clear
  • carb removed, and cleaned three times, diaphragm checked thoroughly and confirmed to be installed correctly float confirmed at 17mm
  • all fuel and vent lines confirmed to be clear
  • jumped on a great price so Dynojet kit installed as per the included instructions
  • clutch removed, cleaned, rollers checked for flat spots, new belt installed
  • confirmed intake tubing all clear, new air filter installed
  • new spark plug installed
  • new plug boot (don't ask what stupid thing i did to require this!!) and plug wire trimmed to ensure proper contact
  • sea foam and star tron added to new premium fuel
  • yes, confirmed I am in high gear and 2wd with diff unlocked
  • yes diode in correctly tried reversing it and confirmed it got way worse way earlier in throttle application
  • no change in the condition when reverse override button pushed
  • checked around carb and intake boot with carb cleaner and propane to check for leaks. None found

Heading hunting next weekend, so have it all back together for now, as I wont need to go WOT, as where we hunt is dry this year. But if there are any other recommendations I should attempt let me know....getting real quick at the whole disassmble and reassemble thing if nothing else....
 

·
Administrator
Joined
·
40,392 Posts
Did you measure the belt to make sure it is in spec ?
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #31 ·
Yes old belt was just under spec, new one was a couple mm wider. Just got back from taking a test ride, everything fine and reuns great until I hit 1/2 throttle and 4,000 rpm, if I give any more throttle above that there is no increase in revs and then after a couple seconds or more, it is almost like spark disappears for a revolution or 2 then backfires back through carb.
 

·
Administrator
Joined
·
40,392 Posts
Does it feel like the rev limiter or it’s running out of fuel ?
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #33 ·
It would be similar to that yes. I just pulled apart and rechecked to ensure everything super clean on carb, and reseated the diaphragm again as well.
 

·
Administrator
Joined
·
40,392 Posts
Put a meter on your diodes and make sure post is only flowing one way.
 

·
Administrator
Joined
·
40,392 Posts
Yep, you only have one ?
 
21 - 37 of 37 Posts
Top