Arctic Cat Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Recently purchased this quad on test drive it rode nice and still does on flat land but reverse it revs high and does little (this bike does not have an override switch) it also is gutless when on a climb at a stand still. It is a semi regular problem , meaning most of the time. I have changed the oil and filter ,same result,, any causes and fixes for this?

Thanks in advance
 

·
Registered
Joined
·
4,275 Posts
Did you use a wet clutch suitable oil? Oil with friction modifiers will cause the wet clutch to slip. Arctic Cat oil or Rotella T6 are a couple good oils.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
Did you use a wet clutch suitable oil? Oil with friction modifiers will cause the wet clutch to slip. Arctic Cat oil or Rotella T6 are a couple good oils.
Update, weird solution. When I bought the bike I noticed the back brake was not attached so he attached it, what that did was engage the brake always and that why it got worse, a friend said it sounded like I was riding the brake and then it clicked. Took off the brake and runs great
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
another update , machine is struggling , high revs little power, idles good , runs hot just lacks response
 

·
Administrator
Joined
·
37,499 Posts
Is it slipping?
 

·
Administrator
Joined
·
7,764 Posts
Rear brakes on an 06 from the foot pedal are useless. What oil did you put in it???????
 
1 - 6 of 6 Posts
Top