Arctic Cat Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Any ideas about my 05 Arctic Cat 500 ATV? It ran fine this spring, used it a few months. Kids were riding it later on and it died and wouldn’t stay running. Brought it home and would only Idle. Try to give it gas and it would die. Had Stabil in the fuel, and tried Sea Foam. Fuel pump was clicking loud so I replaced it. Replaced the electric choke since I heard that could be bad. Cleaned the carb twice now. Cleaned the air filter. It has spark and new gas. All fluids are are good. Had fuel in the bowel when I opened it. I was gonna try look at the fuel filter in the tank next, but I'm pretty much lost on what the problem is.
 

·
Administrator
Joined
·
36,311 Posts
You replaced the vacuum fuel pump?
Check the vacuum line from the intake to the fuel pump. If it gets a crack in the nipple or the line it will run crappy. Do you think it’s a fuel problem or an electrical problem?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I pulled the plug out and it has great spark, so I don’t think it’s electrical. Vacuum is about the only thing that’s left, but I pulled the fuel line from the carb and tried staring it and it seemed to pull fuel fine. I think I’ll pick up some new lines on Tuesday and see if that takes care of it.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Well....I think the vacuum lines are fine. I cleaned the carb again, and put everything back together. Tried starting it and the new fuel pump I just installed blew the top off. Way to much pressure inside, so I think the pump may have been bad to begin with.
 
1 - 4 of 4 Posts
Top