Arctic Cat Forum banner

21 - 24 of 24 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #21
Grunt tool is only to disassemble the primary further if you should need new rollers on the spider. Might or might not need them.
I have taken it apart before minus the spider. I also have a 8.25" clutch that is rebuilt. It does the same thing as the 9 tower when its on. The clutch sheave moves freely and easily. I cleaned everything up. Weights are good and the rollers are good. I was thinking about getting a grunt tool to put new spacers in. I have a bunch of helixes and springs. I was going to throw in a 51° or 53° helix and try that. I can barely rotate the track by hand when its on the stand. I put all new wahl brothers bearings in so I'm not sure whats going on. Its like the brake is on.
 

·
Registered
Joined
·
10,000 Posts
I doubt its the spacers. If you can hardly turn it by hand the track is too tight or the chain in the chain case is bad from lack of oil at some point. You should have 20lb weight in the center of the track and have 1 1/2" sag in it. Almost sounds like a bad drive bearing or the track is out of alignment or something. Have you check track alignment? Did you ever get a chance to check compression?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #23
I doubt its the spacers. If you can hardly turn it by hand the track is too tight or the chain in the chain case is bad from lack of oil at some point. You should have 20lb weight in the center of the track and have 1 1/2" sag in it. Almost sounds like a bad drive bearing or the track is out of alignment or something. Have you check track alignment? Did you ever get a chance to check compression?
Yeah. We loosened the track up a lot. I originally finger tightened the chain. I loosened that a half turn. It could be a bad bearing but again I replaced them all with quality bearings and put in low temp grease. Alignment could be off but I don't think it would affect it this much. I was going to test compression today. Opened my case and found my adapter was missing....do you have a facebook? I could send you the video I took while on the stand.
 

·
Registered
Joined
·
10,000 Posts
Yes, I answered you once on there I thought?
 
21 - 24 of 24 Posts
Top