Arctic Chat : Arctic Cat Forum banner

1999 Pantera 580 EFI Fueling Issue - Seeking Input

3949 Views 25 Replies 6 Participants Last post by  660catman
Hello - New here and seeking some options on what to checkout next, situation as follows:
  • 1999 Pantera 580 EFI with 2,512 miles
  • Started and ran great last season
  • Now the battery is junk, will be getting replaced
  • Also now can only get it to start and run for a brief time by putting fuel into the spark plug holes / cylinders
  • Fuel pump checks out ok
I thought this would / should run without the battery for the EFI but please correct me if I am mistaken. Also, is there some screen or filters that are ahead of the injectors I should be checking for blockage of fuel flow to the injectors? Lastly, any suggestions on the best source for downloading a PDF copy of the service manual?

Thank you in advanced for any input on this one.
21 - 26 of 26 Posts
First off it runs now, i have included my steps for anyone that comes across this problem looking for a STEP-BY-STEP instructional of what i did

Secondly i now have a new issue, that i will list below that i didnt know i had before! FUN!

I replugged in everything, and then I disconnected the ECM, I found the 2 pins the control ground on the injectors, and with the Key in the on position I carefully ( and quickly) jumper-grounded the 2 pins in a tapping motion, I confirmed that the entire injector system after the ECM was working properly on both injectors.

I then attacked the injector sensor on the crank like you spoke of. With the ECM disconnected, i disconnected the plug going to the injector sensor and I confirmed continuity on both wires to the ecm plug itself, I then confirmed that the sensor ohm'd out at 190ish. everything was perfect.

I reinstalled the battery, and at the same time i sanded off the grounding point for the lower bolt hole on the ECM bracketry that connects to the frame of the sled. I turned the key on to get the fuel pump to start up, then after it built up pressure I re-tapped the ground on the ecm plug that controls the injectors to fire to prime the motor a bit instead of using break cleaner. Key off, I plugged the ECM back in, and turned over the motor, it started right up (WTF), it ran like **** for about 30 seconds then leveled out.... i hit the throttle lever and i could tell it didnt like it too much and wasnt "smooth" but after hitting it a dozen or so times, it went back to idle considerably faster than when i first started it. Coolant, oil and fuel levels were all good so i let it sit there and run a little bit to just give it some time to break in/ reseal anything that is super old and hasnt had oil on it in 10 years...

after about 5 minutes I decided to see if my clutches would operate, i ran the RPMS up until the primary engaged, however it didnt even budge the secondary in the process it just bruned the belt... so i turned the motor off and i tried to manually turn the secondary... that bugger is froze solid! there is absolutely no movement on the secondary clutch.

SO my NEW question, is what are the components that would "freeze" a secondary clutch like this? Break caliper, drive selector ( which going from forward to reverse is already difficult) and then there is a chain drive box somewhere ( my experience with chain drive from motorcycles is that normally if they get lodged it will "rock" a little bit, but then rebind the opposite way, which mine is 100% locked/frozen, so i don't think that is the case)? Do you have any pointers on what to look at first? i sprayed as much as i could find with WD-40 before leaving it sit last night, but my plan was to try and mess with it more this weekend. just looking for some direction if anyone has some?
See less See more
  • Like
Reactions: 1
Good to hear about getting it running. More than likely the pads are seized on the rotor. Caliper could be seized too. Worse case scenario the bearing behind secondary clutch seized up but unlikely. Anything in the chaincase should be good as they don’t fail very often.
Remove bolts on caliper and see if it comes off the rotor.
I should say bearings in the chaincase rarely fail. It takes a little effort to put them in reverse. It takes way less to put it in forward. You should remove cover and throughly check and clean it out. Drain is under tunnel on the inside by track.
OK thankyou for helping me out with this, ill pull the break caliper off first and see what i can get to move... if that fails to get it rotating i will start tearing the case apart... ill check back in when i get some answers, but this issue is WAY closer to what i deal with on side by sides and stuff than the early EFI that we were talking about before
  • Like
Reactions: 1
You were 100% spot on, i removed the brake caliper/pads, and it freed up my secondary, i test ran it and everything moved in and out of reverse/forward correctly, i then spread the break pads further with a couple of pry bars and also WD-40'd my brake rotor to give it a little lubrication while the brake pad wore off 10 years of rust.... i reinstalled everything and then ran it a couple of times while slowly applying the break, now everything is working as it should! I am ecstatic! thankyou for all your help Mr. Catman!
  • Like
Reactions: 1
You’re welcome and great to hear you got it!
21 - 26 of 26 Posts