Arctic Chat : Arctic Cat Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Sled is new to me. Just took off the case cover to see how it looked. All looked good. But, can't figure out how to get the cover back on with the reverse fork in the correct position amongst the gears. It came straight off easy....is there a trick to putting this back together? Do I need to adjust the position of the large bottom gear? Would appreciate any help.
 

·
Registered
Joined
·
501 Posts
Sled is new to me. Just took off the case cover to see how it looked. All looked good. But, can't figure out how to get the cover back on with the reverse fork in the correct position amongst the gears. It came straight off easy....is there a trick to putting this back together? Do I need to adjust the position of the large bottom gear? Would appreciate any help.
Not too difficult you need to get clear space around it to work with then the fork for lack of a better word you have to move with the actuating rod in towards the gear a bit so you can see it then slide the cover down while watching the fork and make sure it slips into the 1/4 space between the bottom gear and the gear retainer thats how it pulls the gear to reverse
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Thanks for the reply

Thanks for the reply....you're right, it's pretty straight forward. Got it back together.

Now, outside the case, the reverse linkage / connecting rod that runs down to the bottom is interfering with the battery box when I pull it into reverse. I've tried every adjustment I can see to move the battery box and the reverse linkage stuff to make more clearance. But, that linkage rod (the 8" - 10" long rod) bends against the battery box and the machine won't stay in reverse. I need to make more clearance so the rod doesn't hit the battery box. Any ideas for that one??

Thanks again...
 

·
Registered
Joined
·
501 Posts
Thanks for the reply....you're right, it's pretty straight forward. Got it back together.

Now, outside the case, the reverse linkage / connecting rod that runs down to the bottom is interfering with the battery box when I pull it into reverse. I've tried every adjustment I can see to move the battery box and the reverse linkage stuff to make more clearance. But, that linkage rod (the 8" - 10" long rod) bends against the battery box and the machine won't stay in reverse. I need to make more clearance so the rod doesn't hit the battery box. Any ideas for that one??

Thanks again...
Thats a bit odd,yea its all crammed in there thats for sure but it should not be bending the rod,can you shoot a pic and post up,me thinks something is not original or not placed right,its close and can scrape a bit but not bend,and be careful about adjusting that rod you can throw out the reverse adjustment.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top