Arctic Chat : Arctic Cat Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
I have a stored code for cranckshaft position sensor. With a full battery i go on a drive for 20 minutes and thhe baterry is dead or close to dead. So i assume the stator is bad. I checked with multimeter across all 3 wires and it read 11volts on idle and 9 volts on rpm. Does this mean that the stator is dead for sure or should i check the voltage regulator or anything else. Also when u try and start up when low baterry is sometime flashes EFI.

I apologise for my broken english.
 

·
Administrator
Joined
·
42,420 Posts
Start with the voltage regulator!! Get a free service manual from countrycat.com and do the test procedures.
 

·
Administrator
Joined
·
42,420 Posts
You need to get your battery load tested. Your charging system is working fine. A battery can show full voltage but still be bad. I would suggest you will need a new battery. Most auto parts places will load test for free.
 

·
Administrator
Joined
·
42,420 Posts
As I previously stated, a battery can show good voltage but still be faulty( no cranking amps). Volts is only part of the story. Amps is what cranks your engine.
 

·
Administrator
Joined
·
8,078 Posts
These efi ATV's are very fussy with subpar batteries. Not only that, but the quality of ATV batteries is not all that great. I had a brand new battery last 6 months. Rode it the day before it was fine and the next day it was junk. I like Motobatt batteries but Im reading their quality isnt what it used to be. Still better than most anything out there. A 20 amp/hr battery minimum, but the 25 amp hr battery will fit in that quad as well. If the quad has a winch, power the entire winch rope out, then rewind. If the quad starts after that, your battery is probably okay. I'd either ride it for 20 minutes or put it on a charge. Its kind of a poor mans battery load test. Any auto parts store will load test it for free.
 

·
Administrator
Joined
·
42,420 Posts
This works as well

 
  • Like
Reactions: tiggershark

·
Administrator
Joined
·
42,420 Posts
How did you test the battery ?
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #13 ·
Okay so i changed the stator and now it doesnt start... Cranks up good but no start. Srarts flashing efi. Im going to have to open it up anyways because i messed up the gears on shift lever. Where should i start?
 
1 - 13 of 13 Posts
Top