Arctic Chat : Arctic Cat Forum banner

08 F800 no injector pulse

3339 Views 0 Replies 1 Participant Last post by  tdibble
Looking for help diagnosing a no start condition on a 2008 F800 that was just purchased.
I have good fire and fuel pressure when pulling over. Used noid light and found to have no injector pulse. When I pull the sled over I get 12+ volts DC on the injector harness but I do not get the ground signal from the ECU.
I ohmed the injector harness to the ECU and wires test good. I ohmed ground pin on ECU to chassis ground and have good continuity. Ground location on the stator cover is good.
I would say try the ECU but guy we bought it from said he put this ECU on another sled and it ran good.
I know the ECU takes a reading from the coolant temp, air intake temp, throttle position sensor, and ignitor coils to determine when to pulse the injectors (ground signal). So one of these elements must be bad not allowing the ECU to pulse the injectors?
Previous owner tried a new stator (stator must be good if I get power to injector harness and fuel pump runs?), Fuel pump and tried the ECU on another sled
1 - 1 of 1 Posts
1 - 1 of 1 Posts