Arctic Cat Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I recently bought an 06 f7 and on the very first ride the bearings in the diamond drive exploded. I had a local repair shop replace the bearings and seals. On the second ride the secondary clutch locked up due to the shop not putting the three torx head screws in the end of it. Now on the third ride I find the headlight going out intermittently with the speedo also. I looked at the other threads here and checked the wire to the tail light and it looks fine. Please help!
 

·
Registered
Joined
·
145 Posts
It really sucks when people sell their problem.. I HATE that. Check your harness isn't rubbed bare along the frame beside the engine.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
I wiggled the wires in that harness and it did not seem to make the problem any less or more intermittent. It seems like the lights and speedo go out when the secondary clutch starts to move. I am at a total loss here.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
00zr700, I agree! Especially when the problem that I just bought was recommended to me by a dealer that I have been doing business with for over 9 years.
 

·
Registered
Joined
·
31 Posts
Did you take the gas tank off and check under it? My 04 Sabercat had the brake light wire rubbing the tunnel right after it comes out of the main harness at the front of the tank. About 1 in every 10 times I put the brakes on, the headlight and speedo would blink. Some electrical tape and it works perfectly. I could barely see the spot where the insulation was worn off.
 

·
Team ArcticChat
Joined
·
6,971 Posts
It's been so long since I've had mine.. But wasn't there a wire known to rub behind the secondary? Can anyone verify that ..
 
1 - 13 of 13 Posts
Top