Arctic Chat : Arctic Cat Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
203 Posts
Discussion Starter #1
ive got an 06 f7 efi sno pro d and d ypipe light pipe v force three reeds 2.5 degree timing key fuel programmer and goodwin clutch kit. for this season i added the d and d light pipe and the timing key along with the boondocker programmer. now the sled doesnt exceed 7000 rpms i put a new secondary on the primary is all good just trying to get a couple ideas of what could hold it back and around 5000 rpms it has a slight bog too it as if its too rich but i have no fuel added around 5 grand and the spark plug looks perfect i also bought the pipe from some random guy but could it be an f6 pipe? i know they r different the f pipe looks a little smaller at the throught too the can but i dont know please help thanks
 

·
Banned
Joined
·
1,129 Posts
powervalves. Smartvalves. check those first.

COmpression check, Fresh fuel.

Then check clutching again. What weights?? and springs and helix
 

·
Registered
Joined
·
2 Posts
Is the blinking accompanied with about a 50% loss in engine power? My F6 does this when it has been run moderately hard for a few hours. Once it cools down (no overheat light comes on) it starts up and runs OK. I haven't been smart enough to count the flash sequences, next time I will.
 

·
Registered
Joined
·
320 Posts
Im going through a major bog with my 06 F7...i think i narrowed it down to the secondary bushings. Something to check...i have lots of side to side play when squeezing both sheeves in my hand (with the clutch in the open position obviously). I have 5k miles on my clutch and every part is stock, so im definitly due for a rebuild. Unfortunatly, the bushings aren't replacable in our 06's!!

FYI Backshift is horrible and ill burn my belt if im climbing a steep hill while breaking trail. In deep powder, if i pin it, it will screem to about 7k rpm and slowly fall down to 5k rpm 5 sec. later....its like it goes from 1st geer to sixth then bogs...is yours similar?
 

·
Registered
Joined
·
253 Posts
bad gas

I would lose most of my power. In the UP of MI I had to use some 87. I would hit the trail and the sled would bog down. Then my check engine light would blink a code. I had some 110 octane dumped about a gallon in and back to normal. It has happened twice but only after 87 fuel.
Is the blinking accompanied with about a 50% loss in engine power? My F6 does this when it has been run moderately hard for a few hours. Once it cools down (no overheat light comes on) it starts up and runs OK. I haven't been smart enough to count the flash sequences, next time I will.
 

·
Premium Member
Joined
·
1,759 Posts
first is the sled ported if its not take the boondocker off and run 91 till you port it you good on 91 .sound like your boondocker is not set up.
 

·
Registered
Joined
·
203 Posts
Discussion Starter #8
i hve a new scondary clutch new sheeves and al just put it on and i was thinking about takin the boondocker ff als it wont rn oo lean? and never put lower than 91 octane in itbut its a goodwinclutch kit and powervalves were just cleaned and i am not sure if tey open and close properly or not i will check that would the powervalves not opeing and closing make the sled notrun up to 8000 rpms?
 

·
Premium Member
Joined
·
1,759 Posts
power valves open i think 7300-7400 some wear in there put her on a stand and goose her you should see the little moter wheel turn .
 

·
Registered
Joined
·
203 Posts
Discussion Starter #11
I took off the boondocker and still doesn't run over 7200 rpm still have to check power valves does anyone know what a Goodwin clutch kit runs at at max rpms?
 

·
Registered
Joined
·
203 Posts
Discussion Starter #14
I changed my pipe from the d and d to the stock and it ran great should I invest in the d and d clutch kit for the pipe? Or should the Goodwin kit work fine?
 
1 - 14 of 14 Posts
Top