Arctic Chat : Arctic Cat Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
ok guys i have read all i can on these 700s and im going insane, i have tried every possible thing i can and it just doesnt seem like it use to be. when i bought the sled it had d&d orange primary and d&d 73g weights, with cat green secondary and straight 36*, i thought it pulled hard and rode 2000 miles like this, was great for boondocking in the flatlands, and seemed to climb very well, we ride at 1900 feet elevation, ithen put rock rollers and shift assist, i did notice some rpm drop, but seemed to shift nicer and still work well, then the next ear i played a bit with preload and diffrent springs, both primary and secondary, but we hardly had any sno last yr to ride, so it was impossible to tell anychanges, this year we got tons of snow and i just wasnt impressed, so i asked on here what to change, and i got this... yellow white primary, d&d 73g with orange secondary and 46/40, shift assist, this worked great on trail but terrible in the fields, or and horrible to break trail, great top end tho, so i dropped helix down to factory recomended 44/40 and was alot better, but still wouldnt pull hard as before, so i put the d&d orange primary back in and was better, but now the snow is soo deep and soft here, it seemed too week, now i had a 2inch track on it and it was in poor cond. so i put the ripsaw on it, and it still wouldnt pull very hard, then i bought a new secondary thinking the bushing was pooched, and still not better, lately its been terrible to ride, seemed ok on hard trail, but anything off trail it wouldnt hang skies or nothing, not fun anymore... si i was assuming it was the track change that hurt it,, like it was spinning out, but i see it wold rev to 7980 ish outa the hole and drop to 73ish breaking trail, and if i climb a small hill would be even worse yet, today i took the shift assist out and this thing pulls hard again.. wtf?. hangs skies, holds a consistant 7950 or 798o ish breaking trail and rips on trail, why would this suddenly change?. it almost felt like it was shifting into od too quick and fell on its face , like it would upshift and downshift nonstop, but wouldnt stay put, with the shift assist in, now withut it in it holds rpm and shift better... make sence??. my buddy has same sled and he has had same issues and tonite he took his shift assist out, and it gained 500 rpm aswell, pulling hard.. can someone agree that with snow conditions, it was up/down shifting too easy with assist installed. causing terrible performance off trail???, thanks guys:angry:
 
1 - 1 of 1 Posts
Top