Arctic Chat : Arctic Cat Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter · #1 ·
ok i been having broblems with my cat i had the whole top end rebuilt and the carbs cleaned and jetted has great compression and will start and run but it idles high and can not be adjusted down by the idle screw the real problem is when it under power it will run fine for a minute or two then it stalls and will not start back for a while ( does anyone know what the sytems could be or know what is happening ) ive spent so much time and money tring to get it back to normal im just lost for ansers
 

·
Registered
Joined
·
287 Posts
sound's like a intake leak or something.carb's where jetted up or down? just guessing here but check that the carb idle screw is turning in or is the remote cable adjuster just turning.another thing to try is,spray a SMALL amount of starting fluid around the carb boot area and lower airbox without getting near the airbox intake and see if rpm's increase to help determine intake leak.assuming you have stock intake(no 2"snorkle)and a stock cdialso read your plug's and see if your lean...just some thought.someone here should come along with a cure im sure...good luck....al.
 

·
Registered
Joined
·
140 Posts
Judging by the symptoms, I'd say it is fuel delivery related. Since it will run for a minute or so it sounds to me like the carb float bowls are full and the system cannot replace the fuel in them quickly enough. Have you checked the fuel pump to see that it is pumping to factory specs? Just another thought. It doesn't answer the idle speed issue though.

Rick
 
1 - 3 of 3 Posts
Top