Arctic Chat : Arctic Cat Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
Hey folks, been out of pocket for a long time and now my rig shows it too!

unit sat in the garage for almost 18 months without being started!
I know the carb needs to be cleaned but I have some other questions.

I did winterize it. put new gas in (old plug) but I only have 209 miles on an '05! started right up! ran for about 15 minutes and just cut off and now will not start again.

checked for spark - good (changed plug anyway)
plug is bone dry, the primer lever is soft not what it used to be so I know I'm gonna rebuild but here is my question.

once I took the carb out, had a little fuel in it...
but the tank does not drain. shouldn't the tank gravity drain??? a little????

I put pressure in the tank and still nothing came out of the petcock!!
 

·
Premium Member
Joined
·
1,061 Posts
Sounds like the petcock has some debris in it, or the screen in the tank is clogged. Can you blow back through the carb line and air comes out of the fuel tank?
 
  • Like
Reactions: doublebayou

·
Registered
Joined
·
2,627 Posts
Is the fuel shut off valve even open? 15 mins is the same amount of time it takes my AC to die out once I turn off my fuel shut off valve.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #5 ·
Fuel is definitely ON and not on reserve or off.

Put a clear hose on the tank valve (cap on) and pressured the tank a little, release and it blew air back with just a little gas.

Take the cap off and blew air in and it is definitely going into the tank but it is not making bubbles in the fuel!!!! That doesn't make sense to me.

Turned it to reserve and repeated steps.

There is not a blockage in the valve it simply doesn't gravity drain.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top