Arctic Chat : Arctic Cat Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
279 Posts
Discussion Starter · #1 ·
lookin for a couple of answeres concerning a clutch kit i had installed on my 05 500 auto, requested EPI BIG WHEEL KIT (runnin 27") for low altitude (600'), kit installed is for high altitude (2000+ ), does this affect clutch engagement- performance ?.
next ques. , what colour would the springs be?.

thanx. :beer_cheers:
 

·
Registered
Joined
·
1,283 Posts
Yes it does, the rollers will be lighter.
 

·
Registered
Joined
·
279 Posts
Discussion Starter · #3 ·
<div class='quotetop'>QUOTE (1wook @ Feb 20 2007, 02:17 PM) <{POST_SNAPBACK}></div>
Yes it does, the rollers will be lighter.[/b]
with the lighter rollers is the top end affected under load??, my bot end seems responsive, but as soon as as theres any load above mid range the motor starts to die.( e.g driving thru snow or mud ).can the rollers be causing this?, if so can just the proper rollers be bought or is there also a difference in the springs?.

thanx :thumbsup:
 

·
Registered
Joined
·
1,283 Posts
The high altitude rollers are lighter and should keep it in a lower ratio longer. Call EPI if you want the right ones. What springs are you talking about, the wet clutch ones I assume? They affect the engagement RPM. Did you drill the hole in the retainer plate for the secondary spring? You could try preloading the secondary spring even more, this will also keep it at a lower ratio longer.
 

·
Registered
Joined
·
279 Posts
Discussion Starter · #5 ·
as for the spring colour i was just curious, i asked for all the stock parts back ,8- rollers 4- little springs 1-large spring. stock springs had green stripe painted on them, i dont know about drillin hole in retainer plate as i did"nt inst. this kit , is that part of install?.
PRELOAD ?? how ? .
sorry for the questions, but now that atv is myne (no warr.) i"m just try"in to get educated on things that i"ve havent been exposed to.


thanx again :beer_cheers:
 

·
Registered
Joined
·
1,283 Posts
Yes drilling the hole is part of the instructions with the kit. By changing the location of the hole you can preload the spring more.

For the secondary spring I don't belive any one company offers different options, just one spring rate, each company's rate might be different but they don't have options. So the colour doesn't really matter, the companies offer lots of options for the V2, and coralate the spring rate to the colour.

Are you just curious about this or unhappy with how it's performing?
 

·
Registered
Joined
·
279 Posts
Discussion Starter · #7 ·
i guess it"s the top end perf. under load that bothers me, before clutch kit install, the atv in low never seemed to die when playin in mud. now same mud hole the atv seems to labour in low after clutch kit install,so much so that engine will stall under load bang your head atv motor seems healthy( clean filtr, gas, fuel bowl, muffler,new plug, use sea foam) , also turned pilot screw out 2 1/2.
i this normal, bot end strong , after mid range rpm drops quickly.
i"ve not done any mods, but plannin on installin hidden snorks to help it breathe, maybe this will help.
oh yeah, atv had 1500 miles on it when kit installed,rode 40 miles blew out clutch seal, case filled with oil and soked the belt, installer said belt ok just needed to be cleaned, belt dosent seem to slip. could this be part of the issue?
i guess i"ll pop the cover and have a look see when it gets warmer outside

thanx 1wook :beer_cheers:
 
1 - 7 of 7 Posts
Top