Arctic Cat Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter #1
hello all. my cousins buddys sled is having issues with is 04 f6. when started, it idles high then shuts off. while riding, it bogs down and shuts off but will start right back up. there are no check engine lights. stumped on what it could be, possibly fuel pressure? have no clue. any help is appreciated.

attatched are some vids of the sled running.



-Matt
 

·
Registered
Joined
·
349 Posts
FYI that is an 04 F6 Early Build, there is quite a few differences between that and the 04 F6.

Might check to make sure your fuel filters are not collapsed in the tank.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
67 Posts
Discussion Starter #3
FYI that is an 04 F6 Early Build, there is quite a few differences between that and the 04 F6.

Might check to make sure your fuel filters are not collapsed in the tank.


Sent from my iPhone using Tapatalk
he said filters are good.

and whats the difference between the EBs and the production f6s?
 

·
Registered
Joined
·
349 Posts
Main differences I can think of off the top of my head is the EB’s had the ethanol switch on the dash instead of just a plug near the ecu.

Primary clutch also didn’t use set screw weights.

Dash cluster has a black background instead of the white.

Track rails were updated on the 04’s

Different protector bracket behind the secondary clutch to protect the coolant line.

EB’s use 10 tooth drivers instead of 9 tooth drivers

Probably a few more I can’t think of.

Are you revving the engine when checking the filters? Also I would check fuel pressure


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
17 Posts
Sounds rough

Are the throttle bodies not closing or binding up, allowing idle to be high, may be dying due to TSS (THROTTLE SAFETY SWITCH) if there is slack in the cable

Seems odd that it idles fine then all of a sudden the rpm goes up.. may be air leak..
Check intake boots for cracks, or damage
Check crank seals
 

·
Registered
Joined
·
67 Posts
Discussion Starter #6
Sounds rough

Are the throttle bodies not closing or binding up, allowing idle to be high, may be dying due to TSS (THROTTLE SAFETY SWITCH) if there is slack in the cable

Seems odd that it idles fine then all of a sudden the rpm goes up.. may be air leak..
Check intake boots for cracks, or damage
Check crank seals
will definitely let him know, thanks
 
1 - 6 of 6 Posts
Top