Arctic Cat Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
A friend and i just bought 3 used 2003 f7's. The one i purchased had the computer remaped and clutch kit installed. After riding it for the first time i noticed that it will not run above 7,000 rpms. I put about 50 miles before it developed a very bad low end bog. I changed the plugs and it seemed to wake it up alot but still will not tach over 7,000 7,500 rpms. 2 of the 03's we bought both being mapped seem to b this way. 1 of the sleds being stock runs circles around them. and will show upwards of 9,000 on the tach with no problems. I guess my question is could it b the mapping in the computer that is creating this problem, and if so can i have the computer put back to 2003 specs with out a problem? What does the mapping normally cost? Thanks for the help.....
 

·
Registered
Joined
·
17 Posts
Discussion Starter #2
my bad for being a noob. I have answered alot of my own questions by reading past topics and this site seems to b alot of help. I still have questions about the mapping and what it does or does not do for me?
 

·
Premium Member
Joined
·
1,759 Posts
if i were you i would check your reed and power valve cables if on is running 9000 rpm way to high of rpm should be more 7950 to 8000 and check your fuel filthers in the tank if i were you you mape if it is the new one wont be the problem have fun hope this helps hell cat
 

·
Registered
Joined
·
1,756 Posts
X2 Hell Cat!! just to add... Mapping is free and it helps... APV's are your #1 problem when you can't get over 7000-7200 rpm's.. As for 9000 wow your gonna blow up!!!!! that's gotta be clutching!
 

·
Registered
Joined
·
737 Posts
You can get the ECU remapped to the 2006 specs if you have your dealer send it to A.C. They will not remap an ECU back to the old 2003 map only to the updated map. I believe it is a EPA thing.

Hope this helps Jeff
 

·
Registered
Joined
·
17 Posts
Discussion Starter #6
Thanks Jeff that does answer my question, I answered most of my own questions by reading through the forum. All I really wanted to know is if an updated ecu could be returned to factory specs. The answer I am getting is no... Also sorry to mislead you guys but the 9000 rpm thing was a typo i meant to use it as an estimate and thought i typed 8000. The stock sled is the one that runs good it does not over rev. This F7 in question is new to me and I bought it with 3000 + miles on it and am still trying to figure out exactly what parts have been put in it and why. It is also my first cat, well other than the old kitty kat and my first efi as well. I am going to try servicing the apv's this weekend and see if this helps. The sled seems to run OK just riding it i don't see what all the hype about the 03 f7 really was I have a 440 in the garage that will embarise this thing.
 
1 - 6 of 6 Posts
Top