Arctic Chat : Arctic Cat Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
575 Posts
Discussion Starter · #1 ·
just bought my f7 the other day, test drove it that day and all was good. i pulled sled off trailer, drove it around back yard and noticed what looks like antifreeze sitting under sled. so i popped hood open filled antifreeze container, capped it and started it. almost immediately the antifreeze comes running out of the overflow hose....i think i got gasket issues but not sure. sled supposedly has about 1,000 miles on rebuild. what is causing this and how do i fix and how much is it gonna cost me?? we got snow on the way and wanna have the f7 ready....thanks guys!!
 

·
Registered
Joined
·
617 Posts
Well it may be a pinched O ring in the head! If antifeeze is coming out of the over flow while sled is running!! sounds to me that it's being compressed out of motor! A bad seal somewhere! Hope this helps ! Not much more I can say! I'd start looking at the head first! They are not that easy to get them 4 o rings to stay in place when you put the head back on! Some guys use grease to hold em in place then ya put head back on and torq her down to spec! Following the correct sequence to tighten each one.
 

·
Premium Member
Joined
·
3,390 Posts
yep
you can take the head and old oring to bearing service and usually they have them in stock if your local dealer does not
 

·
Registered
Joined
·
575 Posts
Discussion Starter · #6 ·
Hello guys, took my sled to my master mechanic aka my uncles lol and took head off. Sure as **** the two inner orings are bad. Ones cracked and ones stretched way out. $60 later got all 4 orings b4 work and will be back together and runnin by noon tomorrow.
 

·
Registered
Joined
·
575 Posts
Discussion Starter · #7 ·
Hey all....i got a snopro track on my sled non studded. I wanna order studs. How many shud i need and how long of studs, im not home so i cant go measure my lugs. Who sells good studs for not alot of $?
 
1 - 8 of 8 Posts
Top