Arctic Cat Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Looking at it for a friend, idles and pulls smooth initially, then feels like a (reverse?) rev limiter engaging. He replaced the carb, no change. Charging voltage is good. Fuel supply is good. Gear indicators work except for neutral. Is there a reverse gear rev limiter that may be enabled when it’s not supposed to be? Anyone have a wiring schematic they could share?

Thank you for any help
Jeremy


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
11,094 Posts
I know you said charging voltage is good but does it maintain 14.4 volts at idle and revved up with lights on and lights off?
Wiring diagrams are available at country cat . com for a free download under technical information. You need to download it in order to properly rear it in a larger font.
 

·
Registered
Joined
·
11,094 Posts
Is that revved up too? I edited my first post for wiring diagrams
 
  • Like
Reactions: rnmdad

·
Registered
Joined
·
9 Posts
Discussion Starter #5
I know you said charging voltage is good but does it maintain 14.4 volts at idle and revved up with lights on and lights off?
Wiring diagrams are available at country cat . com for a free download under technical information. You need to download it in order to properly rear it in a larger font.
I’ll double check tomorrow to be sure. No change in voltage with the lights, regulator seems to be working with the load.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
I know you said charging voltage is good but does it maintain 14.4 volts at idle and revved up with lights on and lights off?
Wiring diagrams are available at country cat . com for a free download under technical information. You need to download it in order to properly rear it in a larger font.
13.5-14 lights on or off, even at higher RPM


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
11,094 Posts
That’s good but blows my theory.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #8
It doesn’t look like there’s a no-load or reverse rev limiter on these, just the limiter built into the CDI, can anyone verify that?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
11,094 Posts
All the manual 300, 400’s and 500’s don’t have a reverse override button like the automatics.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #10
Resistance tested the CDI, not even close to the values in the manual. Bad CDI wouldn’t run at all? Or am I wrong?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
11,094 Posts
I’m not 100% sure. I thought there is no test and a known good one should be used for testing.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #12
Bunch of pin to pin ohms checks. Owner has a 2002 250 that we can borrow the CDI from to test, I’ll let you know how it goes


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
9 Posts
Discussion Starter #13
CDI is not the issue. Swapped a known hood, no change. I’m swapping the old carb back on to see what that does. I’ll be back


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
9 Posts
Discussion Starter #14
Follow up. Ended up being carb issues. Aftermarket replacement was too big and jetted wrong. I was able to get the jetting good enough, runs pretty okay. Thanks for the help, I’m sure I’ll be back


Sent from my iPhone using Tapatalk
 
1 - 14 of 14 Posts
Top