Arctic Chat : Arctic Cat Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-9 of 9 Results
  1. Vintage 1992 & Older
    What can I use in place of the BR10EV plugs that came standard with the 81 El Tigre 6000? I tried the BR10EIX as that's what NGK said is the new replacement for it but my sled ran like crap on them. Can I use a BR10ES or what are some other good options out there? Thanks!
  2. Utility ATV repair, maintenance, troubleshooting
    Evening Guys I have got a 2007 AC 400 4x4 Automatic TRV plus I am trying to figure out the correct Spark plug for this engine? Is there a stamp on the cylinder anywhere as well? I think its the 376cm3. Shes running a bit lean i think as well as exhaust gets very hot ? Could anyone shed any...
  3. Vintage 1992 & Older
    Hey guys I’m new to this group and wondering i anyone else ran into this problem. Sled ran good last Yr but this Yr it fires up right away, idles good, once you’ve been driving it for 10 min ish it dies. Drive side plug is brown/white and mag side is wet. Checked compression both cyl 110psi...
  4. Utility ATV repair, maintenance, troubleshooting
    My 2001 arctic cat atv all the sudden wont start with electric start. It worked earlier now it doesn't make a sound. Lights are on bright and tried for better connection with battery, looks good there. I was Finally able to pull start it 1 time but now can't even do that. Any ideas?? Starter...
  5. M Series/Mountain Cat Pre 2011
    I have a 2007 m8 153 with and slp can. When I bought the sled it had br10es spark plugs in it I was curious of they were fine to run or if I need something different? Sled works fine no codes or problems any advice is welcomed thanks.
  6. Z/ZL/ZR/ZRT/T-Cat/EXT/JAG/Cougar
    I have a 98 zr 500 and the old clutch that was on it was gabage it had crazies throught and the weights dug right into the sides, so I bought a new clutch just a powerblock 50 from royal distributing I just put it on today took it for a ride and noticed a delay on the take off when I punch it it...
  7. Utility ATV repair, maintenance, troubleshooting
    i have a 08 arctic cat 700 efi suki motor and i looked on here for proper gap and i came across .30 but i looked in the online manual "K&T Parts House Lawn Mower Parts and Chain Saw & Trimmer Parts" and all i can find there is .7 - .8 so .7 - .8 is correct i assume....just making sure there isnt...
  8. Utility ATV repair, maintenance, troubleshooting
    My Atv has a brand new carb and I cleaned the gas tank and fuel line filters prior to installing carb. The atv ran great for about a month with me putting about 20 miles on it and then all of a sudden I started it one day and it beagan cutting out at full throttle. I drained the fuel and sprayed...
  9. Utility ATV repair, maintenance, troubleshooting
    OK, I have an 08 700 EFI ATV. I love this thing and it only has about 100 miles on it. I just changed the oil and cleaned it up and now it won't start. So I figured it is probably the plug and thought I would go ahead and put a new one in to start there. This is where all the trouble came...
1-9 of 9 Results
Top