Arctic Chat : Arctic Cat Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-11 of 11 Results
  1. General Snowmobile Discussion
    I have a 2005 Z570 I purchased in 2018. Lack of snow in NE plus 2 babies, I wasn't able to ride it until last season. Fuel consumption is terrible to say the least. Used a full tank on a 33 mile run. Had a local shop look at it at the end of last season and they told me the clutch needed to be...
  2. Arctic Cat Snowmobiles
    Hi Everyone, I am in a bit of a situation and looking for some advice as to what I should do next. I have a 2015 XF8000 and I snapped the part of my E Start mount that holds the shaft in place. (pictured) I am trying to get to that mount to remove and replace but it seems like my only option...
  3. Firecat/Sabercat
    Hi, I am new to the forum as this is my 1st post, sorry if i am doing something wrong. But just welcoming myself to this section of the forum as i own an 04 f6 and i have been having a problem with it wondering if anybody could offer me ideas, Alright so here is the deal, My firecat will only...
  4. CrossFire/CF/CFR 06-11
    Im having some trouble wiht my CF had this problem before but it was solved with a heater under the hood for a few hours. Tried it again and it wont start, worked fine yesterday. Heard some sound that was similar to when you shut down a gas burner like a Poof, happens when i shut the sled. All...
  5. Firecat/Sabercat
    Last night we received about a foot of snow so i went to take out my sled like any sane person would do. I fired it up like usual and as soon as i flicked the break lever to put it into high beam every single light blew out and all the lights such as check engine came on very dimly on the dash...
  6. General Snowmobile Discussion
    hi, my snowmobile lights and gauges went out last year, they would occasionally come back on for 10 seconds, then go back off. Any suggestions on where to look or what it could be? thanks
  7. General ATV Discussion
    i purchased 2 brand new arctic cat 450 atvs. both machines have around 30 hours on them and are only 3 months old. the same day both egine block/casing cracked at identical spots (right by oil dipstick) and proceeded to crack to the rear of motor. Causing all oil to drain out of the engine. I...
  8. Firecat/Sabercat
    My electric start on my 2006 Sabercat 700 EFI LX doesn't work. Sled runs fine when you pull start. When you turn the key it just clicks. The sound seems to come from the solenoid. The guy I got it from gave me a new solenoid which I changed and it does the same thing. Anybody have any...
  9. General Snowmobile Discussion
    Hi Everyone. I have been all over this forum. Great help. Done all as described Replaced stator coil fuel rail/injectors air temp sw plugs checked compression 115lbs bypassed TSS fuel pressure 38 lbs still boggs on acceleration. The only thing we didn't replace was the battery and cdi and ECU...
  10. M Series/Mountain Cat Pre 2011
    I have a 2005 m7 162 and ive gone through 4 mounts now for the front right idler wheel. It is on how it is suppose to be and wheel is actually smaller than OEM. i need answers. thanks!
  11. General ATV Discussion
    I have a 2000 Artic Cat 500 ATV with winch and plow. Recently the battery started to die. When I check voltage at the battery it seems to be charging at only around 11 volts. If I leave the lights off and don't use the winch it will go a few hours before the battery gives up, if I use those...
1-11 of 11 Results
Top