Arctic Chat : Arctic Cat Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-20 of 36 Results
  1. Arctic Cat Snowmobiles
    I have a arctic cat ext 580 powder special and I don’t know where to plug in the timing sensors.
  2. Arctic Cat Snowmobiles
    I got a artic cat ext 580 powder special and it gives no spark, the snowmobile has no ecm, no battery and no ignition timing sensor, and there is a four pin connector going from the magneto that is not plugged in to anything, can anyone tell me if I need any of those parts If not I need to know...
  3. General ATV Discussion
    So, ive been working on my tbx 500 2006 and found a wire connected to nothing. After some reaserch, i discovered it belonged to the water temp sensor on the motor bloc. Can anyone tell me where this plugs into and what being unplugged does for the atv please?
  4. Utility ATV repair, maintenance, troubleshooting
    i have a 1999-2001 arctic cat 450 and its stuck in 5th gear the transmission is manual do you have any idea what the problem could be?
  5. Utility ATV repair, maintenance, troubleshooting
    Hello everyone, I’m new to the forum and first time Arctic Cat owner. I have recently purchased a 2000 Arctic Cat 300 4x4. It’s rough but runs and drives and the price was right. It has an engine oil leak on the right side cover gasket. How do you get the cover off to replace the gasket without...
  6. Z/ZL/ZR/ZRT/T-Cat/EXT/JAG/Cougar
    Hi guys, looking for some insight on my efi ext 550. No much experience with the EFI sleds. Was a cheap non running sled, the wiring had been butchered for the kill switchs when I got it but I sorted it out. But still doesn't seem to want to fire. Has good spark, good compression, fuel pump...
  7. Arctic Cat Snowmobiles
    As you can see above… looks like a roller snapped on my 2005 f6 clutch. Wondering if this model sells just the roller? Looks like I could still re tap the hole and insert one. Wondering if I have to buy a whole new spider or primary? Any help would be great. Sled is engaging at idle and bogs out...
  8. General Snowmobile Discussion
    I have a 2005 Z570 I purchased in 2018. Lack of snow in NE plus 2 babies, I wasn't able to ride it until last season. Fuel consumption is terrible to say the least. Used a full tank on a 33 mile run. Had a local shop look at it at the end of last season and they told me the clutch needed to be...
  9. Arctic Cat Snowmobiles
    Hello all. Jut picked up a good older sled and it needs wear bars but I'm having a hard time finding some that fit. I have the Usi px 301 ski's which are old but still in great shape. Maybe I'm an idiot but even the USI website didn't have any info on the px 301. Any direction in finding a...
  10. Arctic Cat Snowmobiles
    My primary on my 1978 jag engages sloppy what could course this and what could I check when it’s disassembled
  11. General ATV Discussion
    2009 crossfire 1000r 4800km. Sled looks in very good condition and well maintained. Looking for opinions on who’s owned one and if I should pick it up. There is also a 2006 crossfire 700 both near same in price.
  12. Arctic Cat Snowmobiles
    Bought this sled a year ago for my wife and was wanting to replace the belt. Does not appear to look like anything I’ve seen on YouTube. Any help Is appreciated! Sled is a 2005 AC M7 141”. Attached are pictures of the secondary. Thanks! On the end it says AMP, not sure what this piece is, I’ve...
  13. Z/ZL/ZR/ZRT/T-Cat/EXT/JAG/Cougar
    Trying to replace all 4 drive bearings in my 2006 z570lx. When reassembling I could not remember or figure out where the v ring seal for the chain case goes on the driveshaft. I have a service manual but it mentions nothing about a seal and one definitely came off of the sled when disassembled...
  14. Utility ATV repair, maintenance, troubleshooting
    Hey guys Picked up a 2001 Arctic cat 500 4x4 with 600km on it recently and it’s got a few issues. One of the major ones is that the battery won’t hold a charge. I put a brand new battery in which worked for a short time but now I get no power. Wondering if it is the stator? Is there a way of...
  15. Z/ZL/ZR/ZRT/T-Cat/EXT/JAG/Cougar
    I have a ZRT 800 with no spark. (purchased it this way) its beginning to blow my mind on why it wont work. Stator tests out fine but for the life of me when i pull it over i cant see any voltage coming out of the stator. Key and tether were eliminated by previous owner (not sure how it was...
  16. General ATV Discussion
    I have a artic cat 300 1998 4x4 and when i drive it ot goes around 25% power and takes 10 seconds to kick in to full power. What would be the issue
  17. Arctic Cat Snowmobiles
    I can’t get it to idle it starts find and I can rev it I’ve looked everywhere and can’t find anything wondering if anyone could help
  18. Prowler
    Hey everyone. So have a bit of a nightmare. 2 years ago my 2011 hdx prowler 700 decided to split the head and had bad play i bottom end. Took it to a "I can fix it cheaper" guy who didnt know what they were doing yes I know stupidity on my part. But now i have a box of parts and no on really...
  19. Utility ATV repair, maintenance, troubleshooting
    Hey everyone. So I just picked up an 04 650 cat with the Kawasaki v twin motor. It wasn't running when I got it due to a bad fuel line, dirty carbs, no battery. After all were taken care of I took it out for a ride. It seems to run great, it idles nice, and start decently when cold (there's no...
  20. Utility ATV repair, maintenance, troubleshooting
    I have a Arctic cat 300 and it starts fine but when i go to move it, it wont move. Idles fine but when i go to move, it acts like its in reverse safety mode (it does not have one) and starts chugging to the point the transmission wont engage. If anyone knows anything about this issue let me know.
1-20 of 36 Results
Top