Arctic Chat : Arctic Cat Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-4 of 4 Results
  1. Utility ATV repair, maintenance, troubleshooting
    I Recently picked up a used 2008 Arctic Cat 366 4x4 and noticed that the buttons next to the speedometer do not work. However the speedometer works and so does the gear indicator and the high beam light. Has anyone else had these issues? If so how did you fix them. Also I looked online and...
  2. Firecat/Sabercat
    During my last ride of last season my gauge pod flickered a few times then stopped working completely. I figured it was a bad gauge pod and purchased a new 1. That's apparently not the problem. Next I replaced the wiring harness from the module to the gauge pod, it's still not working. The sled...
  3. Z/ZL/ZR/ZRT/T-Cat/EXT/JAG/Cougar
    I've got a 1996 ZR 440 and the handwarmer has been acting up late last season, as in sometimes working sometimes not. This season it continued this behavior but one day I noticed the RPM gauge quit working. Then the next trip I took the speedometer quit working and now also the headlights and...
  4. F/M/XF/ZR Procross Chassis 2012+
    I was out this weekend and my gauges went out. The sled ran like crap after that. Pull the hood and locate the fuse box. It looks like a dead end wire with a cap on it, blue at the base. The 7.5 amp fuse was blown. I didn't have another one so I just took one of the 15 amp one out next to it to...
1-4 of 4 Results
Top